annotateMyIDs fatal error code 1

Hi everyone

I have tried to annotate my geneID con this app but an I don’t get success. I have inputted the count table from featureCounts with Ensembl human nomenclature e.g ENST00000000233.10

Execution resulted in the following messages:

Fatal error: Exit code 1 ()

I have tried either Ensembl gene and Ensembl transcript and It didn’t work.

My table has a header

Thanks for your comments

1 Like

Hi @andres2r89

These are Ensembl transcript identifiers, not genes.


  1. Accept that the counts will be “by transcript” and not “by gene” and remove the .NN where N is the version number after the dot.

  2. Choose a different reference annotation GTF dataset where the gene_id attribute is actually a gene. Some data providers host GTFs where the transcript_id and gene_id are the same within a GTF dataset.

  3. Use Featurecounts for generating counts and use the built-in annotation (Entrez).

I’ve added some tags to your post to help find prior Q&A about this kind of content and potential solutions.

These FAQs may also help:
*Help for Differential Expression Analysis

Hello @jennaj

How I can select rows with a specific condition, e.g gene codified to miRNAs?

I tried to use ‘filter’ and ‘select’ but it didn’t work

Thanks for your support!

1 Like

Hi @andres2r89

miRNA analysis involves different tools and reference data than standard RNA-seq protocols.

Please see these prior Q&A topics: Search results for 'mirna' - Galaxy Community Help

Includes your prior post: miRNA featureCounts

With more help here: Searching the Galaxy