Built-in join1 and sort tools errors

Hello dear community, I have just started using galaxy on a local server, followed a few guides, and stopped at one of them where I needed to use join tool…
All good, except 2 “errors”, one a lot more important than other.
When running join tool for the “Data Manipulation Olympics” - training I have encountered this error, I have tried other variations with this tool - same error…

Join two Datasets side by side on a specified field - error
Traceback (most recent call last):
File “/home/arian/galaxyproject/galaxy/tools/filters/join.py”, line 19, in
from galaxy.util import stringify_dictionary_keys
ModuleNotFoundError: No module named ‘galaxy’

With Sort data in ascending or descending order (built in tool) – is simply loading indefinitely without an error - but I have installed another type of sort tool (of the same kind), and it works flawlessly, but still I’d like to understand why it’s not working…(unfortunately I don’t have an output error)
Could anyone help me?

Hi @apolitics,
thanks for the report. We have been informed previously about those bugs:

Sorry for the inconvenience.