BWA-MEM Index can't be found

I’m using a usegalaxy.org instance to analyze illumina data (paired end, trimmomatic trimmed) to a reference fungal genome (one I downloaded from Ensembl). I am using BWA-MEM in paired-end mode, but I think that it is failing in the indexing.

Every time I run it, I get this error:

[E::idx_find_and_load] Could not retrieve index file for ‘/galaxy-repl/main/files/042/990/dataset_42990690.dat’
[E::idx_find_and_load] Could not retrieve index file for ‘/galaxy-repl/main/files/042/990/dataset_42990690.dat’

Anyone have any suggestions?

1 Like

Hi Rachel, are your datasets green ? This message is emitted by pysam before we index the bam file. If it is green there is nothing to worry about.

Thanks for the quick reply! The job is red indicating a failure. And this is the last thing it says before it fails. I was able to run the fastq files and genome through bwa mem using the standalone programs on the same files though. I ended up using the command line software to generate my bam files and moved those back to Galaxy for the rest of the analysis. Still no idea why it failed on the BWA-MEM step, but I was able to work around.