Hi, All. When attempting to update to v22.01 using ansible, we seem to be running into a version conflict between the versions of cwltool and pyparsing requested in galaxy/server/lib/galaxy/dependencies/pinned-requirements.txt. The exact error is:
The conflict is caused by:
The user requested pyparsing==3.0.7
cwltool 3.1.20211107152837 depends on pyparsing!=3.0.2
cwltool 3.1.20211107152837 depends on pyparsing<3; python_version <= "3.6"
Any suggestions for resolving this would be greatly appreciated.