DESeq2 error running htseq-count

Every time I run DESeq2 I get this fatal “undefined” error:

estimating size factors
Error in checkForExperimentalReplicates(object, modelMatrix) :

The design matrix has the same number of samples and coefficients to fit,
so estimation of dispersion is not possible. Treating samples
as replicates was deprecated in v1.20 and no longer supported since v1.22.

Calls: DESeq -> DESeqParallel -> checkForExperimentalReplicates

I’m running DESeq2 under default conditions with two samples processed successfully through htseq-count and asking it to output the rLog normalized and normalized count files.

I’m not sure what I’m doing wrong, but for what it’s worth I have yet to get DESeq2 to work on anything I’ve attempted thus far over the course of a few weeks and have not found any helpful information in the forum. So, any advice or consultation would be GREATLY appreciated.


1 Like

Hi @npokorzynski

Replicates are required. Maybe that is what is leading to errors?

This FAQ should help:

Differential expression is also covered in the GTN Tutorials. Look in the topic Transcriptomics. You can also search by tool name to find those that include the tool(s) you are interested in.

And I added a few tags to this and the other similar post. Reviewing what fixed prior issues for others may help to resolve yours.


Thank you for the reply - replicates may be the issue. I’ll update if I run into further problems.

1 Like