FASTQGroomer Error

My original files for a RNA-Seq-analysis are in fastq.gz format and to map (with BWA-MEM) them I tried converting them to fastqsanger format using the FASTQ Groomer. When doing so I received the error “There was an error reading your input file. Your input file is likely malformed.” regarding some of the files.
However, I don’t think there is any problem with my data files. How can I check them?
I have already tied to redo the jobs (grooming, mapping) after also re-importing the files.

Hi @Iisa

If the reads were generated from a recent Illumina protocol, they are already in fastqsanger (uncompressed) or fastqsanger.gz (compressed) format.

Try running FastQC on the reads. If that tool also fails, there is either formatting or datatype assignment problem:

  1. The uploaded read could be truncated (before upload, or during). Check the size in Galaxy versus the size from the source. Uploading again resolves this.
  2. Check to make sure that the file is actually compressed or not, and adjust the datatype to match.
  3. If you can’t find the problem, please share your history back for more help. You can post the link back in a public reply or ask for a moderator to start up a private direct message here instead.


FAQs – these cover most fastq datatypes with extra help

Hi @jennaj,

Thank you for your advice.
I have tried to run FastQC with varying results, which I am not quite sure how to interpret. I would be very appreciative of a private conversation with a moderator.