Galaxy doesn't allow Cloud Authorization - Save Key button deactivated

Hi,
I have a problem with the Cloud Authorization option on Galaxy.
I followed these steps:

  1. I log in to my account at usegalaxy.org
  2. I click User -> Preferences -> Manage Cloud Authorization ->Create New Authorization Key
  3. I pick Azure and enter my details, but the Save Key button never gets activated.

I also tried installing Galaxy locally and followed the same steps, but the button never got activated.

I was wondering whether anyone has had a similar problem and could give me some advice?

Thanks in advance!

1 Like

Hi @rainbowmiha

Apologies for the delay. This is beta functionality, and it should not be displayed.

We will be making adjustments to how this particular “beta” is status is communicated in deployments. Most likely the function will be de-activated until finalized.

Development ticket if interested: https://github.com/galaxyproject/galaxy/issues/10922

Thank you for reporting the problem!

cc @mvdbeek @vahid

Hi @rainbowmiha,

Thank you for testing this feature. As @jennaj has mentioned, this feature is in beta status, and it seems it is broken through-out the development.

We will fix the UI, meanwhile, you can create authnz using Galaxy’s API. For this, you may run the following (replacing ... with your values) in your terminal:

curl --header "Content-Type: application/json" \
--request POST \
--data '{"provider": "azure", "config": {"tenant_id": "...","client_id": "...","client_secret": "..."}}' \
https://usegalaxy.org/api/cloud/authz?key=...

This will return the configuration created in json format. For instance:

{
    "model_class": "CloudAuthz",
    "config": {
        "client_id": "...",
        "client_secret": "...",
        "tenant_id": "..."
    },
    "user_id": "...",
    "last_activity": "2020-12-15 15:37:56.123303",
    "create_time": "2020-12-15 21:37:56.125248",
    "description": "",
    "last_update": "2020-12-15 15:37:56.123284",
    "id": "...",
    "provider": "azure",
    "authn_id": null
}

Then you should be able to use id to use the cloud storage api; send data to Azure or get your data from Azure to Galaxy.

However, at the moment, there is a bug using this feature on usegalaxy.org as this feature requires OIDC which is not yet enabled on usegalaxy.org.

I created an issue for the UI and another one for azure on usegalaxy.org.

1 Like