How can I modify tool dependencies?

Hi,

I am running a local galaxy instance and encountered following error after running “volcano 0.0.3” i recently installed from the repository:

Fatal error: Exit code 1 ()

Warning message:

As of rlang 0.4.0, dplyr must be at least version 0.8.0.

✖ dplyr 0.7.8 is too old for rlang 0.4.4.

ℹ Please update dplyr with `install.packages("dplyr")` and restart R.

Warning messages:

1: The `printer` argu

Now I have searched for an easy method to get the dependencies updated to version 0.8.0 but I am pretty lost on how to do this. I tried to find the conda environment used to install the dependencies and just update it in there, but I cant find the correct conda env.

I tried to edit the tool.xml of volcano to automatically install a newer r-dplyr version, but I also cant seem to find the correct file for this approach.

Can anybody tell me the easiest way to get the dependencies update done? Besides contacting the author of the tool and waiting for an update.

thanks,

1 Like

The easiest fix is contacting the author of the tool (https://github.com/galaxyproject/tools-iuc/issues) and describing the problem there.

1 Like

You could check the admin page and then go to manage dependencies.

I tried to edit the tool.xml of volcano to automatically install a newer r-dplyr version, but I also cant seem to find the correct file for this approach.

Think you can find it here (I checked V19.05):
/galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/iuc

1 Like