No matching distribution found for adal==1.2.5: Troubleshooting local Galaxy installation under WSL (Windows 10)

When running sh, the following error occurs:

WARNING: Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'NewConnectionError('<pip._vendor.urllib3.connection.HTTPSConnection object at 0x7f42e08aa0b8>: Failed to establish a new connection: [Errno -2] Name or service not known',)': /simple/adal/
ERROR: Could not find a version that satisfies the requirement adal==1.2.5 (from versions: none)
ERROR: No matching distribution found for adal==1.2.5 

I tried to instal adal version 1.2.5 to galaxy environment but the error remained.
The OS Iā€™m using is WSL. Could this be the root of the problem?

I see you posted this question twice, I guess it was a mistake, can you delete the one that you dont want? :slightly_smiling_face:


It could very be a WSL thing, I dont know much about it but it could be a firewall isseu.

Sorry, my bad. The duplicate has been removed

A strange thing have happened as I restarted my computer - now it works like a charm and has no errors. Prior to that, I started to try few solutions and made few actions:

These steps (including the restart of the computer) might have no influence on resolving this problem so I am not sure if we can call it as a solution.

Yet, the problem somehow has been solved.


Good to hear, thanks for the follow-up.

1 Like