$output.files_path points to wrong directory is there a fix?

Many of my Qiime2 tools are failing in Galaxy because the wrapper outputs additional html files to $output.files_path, however ‘files_path’ is showing that it is the current job directory Ex: ‘database/job_directory/000/’. The issue seems to be that the files are getting saved to the job directory but $output points to the directory 'database/files/’ directory Ex: database/files/dataset123.dat.

From all of the support I’ve seen online nobody else has had this problem is there a way around this? or at-least to get the directory of the output file without the name of the file?

Here is a snippet of the code I am referring to, Thank you!

qiime tools export --input-path input.qzv --output-path out && mkdir -p ‘$output.files_path’
&& cp -r out/* ‘$output.files_path’
&& mv ‘$output.files_path/index.html’ ‘$output’

I am a normal user like you but I think if you want help from a developer you need to show more of your xml wrapper.

As far as I know the job directory is where the programs and scripts run and will be deleted when the tool is done. The files folder is used to store the output files that you will see in your browser. I think your code should look like something like this (on top of my head):

qiime tools export --input-path input.qzv --output-path out && mkdir -p ‘output_folder’
&& cp -r out/* output_folder
&& mv output_folder/index.html "${output}"

You can also use “from_work_dir” see more info here: https://docs.galaxyproject.org/en/latest/dev/schema.html#tool-outputs-data

(Again on top of my head so don’t copy paste) it can look like something like this:

qiime tools export --input-path input.qzv --output-path out

<data format="html" name="htmlout" from_work_dir="out/index.html" label="index html" >
1 Like

Thank you again, I tried those suggestions but they still didn’t work. I am currently getting assistance on the Galaxy chat site on this issue it seems theres an issue with my files path and extra files path properties.