Problem using Import Anndata tool

Hello
I used Import Annadata and loom to process my single cell data
My genes file included 28 thousand gene symbols and ensemble IDs
Now, although the output of this tool is green, the number of genes is considered zero
And in the matrix he created, my genes are not there
what is the reason?

Hi @maryam-gh99

Some tools do just output nothing if there are technical “mismatches”.

Items to check for:

  1. Unexpected content/format in your input datasets versus the tool form parameters (usually involves datatype issues).
  2. Differences in ID formats contained in different input datasets and/or server indexed reference data (important “keys” like gene names).
  3. The tool form may be set up to look for specific attributes that are missing from the inputs (example: loom inputs have several default keys set for data parsing-- does your data contain those same keys?).

And, there is a version of the Import Anndata and loom tool at that should be avoided. AnnData Import/ AnnData Manipulate not working?.

Single cell tutorials are here:


If you need more help, please share more details. Considering sharing your history – as this tool processes several different input/output types and those details matter. Leave any inputs and outputs undeleted, and note the output dataset number that is unexpectedly empty.

Thank you for your guidance
I spent a lot of time correcting my input files, especially the genes file
And I tried to prepare my input files according to what I learned in the tutorial Clustering 3K PBMCs with Scanpy
My genes file had a lot of problems, but I corrected it as much as I could and found ensemble IDs related to gene symbols.
Now I don’t know if the problem is with my genes file or something else
Doing this project is very important for me
Please help me if you can
I think I can’t send you my history link according to the instructions
And I don’t know how to share it with you
But I think if you saw my history, you would be able to understand what I mean better

If you are working at a public Galaxy server, creating a shared link to any history in your account should be possible. Create the link, then copy and paste it back to this topic in a reply.