run Unicycler always got " unicycler: command not found"

run Unicycler always got “/jetstream2/scratch/main/jobs/47842391/command.sh: line 110: unicycler: command not found”

I am wondering if there are something wrong with my input data or there is something wrong with the Unicycler?

Thanks.

Hi @Meadowlawn

I reproduced the issue with Unicycler. I hope it will be fixed soon.

@jennaj It seems there is an issue with Unicycler on usegalaxy.org.

Kind regards,

Igor

Hi Igor,

Thank you very much for quick reply. I tired today and found it still does not work.
Current error is “line 10: unicycler: command not found”. The error changed from “line 110 command not found” to “line 10 command not found”

Thanks again,
Guowu

Hi Guowu,
if you need results urgently, maybe copy FASTQ files to another Galaxy server, such as usegalaxy.eu, and complete assembly over there. It is OK to have accounts on several public Galaxy servers.
To copy a file, click on dataset name in history on ‘source’ Galaxy, click at Copy Link (chain icon), on ‘target’ Galaxy activate Upload menu, switch to Paste/Fetch Data tub, paste the link and hit Start.
Kind regards,
Igor

Hi Igor,

Thank you for the instructions. I will try it. When do you think it will be fixed?

Thanks again,
Guowu

Hi Guowu,
unfortunately, I don’t know, but I copied my reply to Jenifer.
Kind regards,
Igor

Update Jan 24 2022

All test runs for the three most current versions of Unicycler were successful. I’m going to consider this issue resolved/closed unless a bug report for a job run from now forward is sent in. If doing that, comment here and include a link to this topic in the bug report comments to help find it.

Public test history based on tutorial data: test-history-unicycler


Hi @igor

I started up some tests but had to restart again. Still running now.

@Meadowlawn – would you please

  1. try a rerun now in a clean history
  2. be sure to use the most current version of the tool
  3. if you have not done QA steps on the reads, do that first, then assemble
  4. if the job still fails, please submit a bug report from that history and the errored run. It would be helpful if you posted in the URL for this question into the comments field.

Unicycler requires uncompressed intact pairs of short reads (Illumina) and optionally long reads (ONT, etc). If the tool cannot read the inputs, it can error with the message you received.

Tutorials

Hi @jennaj
I am still getting errors with Unicycler on the main Galaxy server; the last on was on January 25th:

I don’t have problems with the same datasets, both fastqsanger and compressed versions, in Europe. The same version of Unicycler was used with the default settings:
https://usegalaxy.eu/u/igor/h/unicycler-test
I know I am absent-minded, but I could not figure out what I am doing wrong: select Unicycler, select input files, click Execute or Run Tool. The only difference I found is in Galaxy versions: the main server has 23.0.rc1, Europe uses 22.05. I have a normal user account on the main server and in Europe. Any chance it works for admin accounts only?
Kind regards,
Igor