Sixpack tool running error

Hi, I am trying to use sixpack to translate fasta nucleotide data into all 6 reading frames.
Hovewer I get an error each time I try.

An error occurred with this dataset:
format sixpack database ?
Died: Value required for ‘-uppercase’ before ‘-number’

Have tried with both single fasta and multifasta, both produce the same error.
Fasta file is plain text and other tools like seqret works and converts the fasta files. Here is an example:


Anyone have a solution to this issue?
For some reason the “>” before contig is not showing on the post. It is visible when I edit this post tough?
Fasta format with “>contig_10” is followed.

Edit: change in problem description :slightly_smiling_face:
I am not sure about the error but the format is not a valid fasta format. The title or description need to start with a “>”.

Hi, sorry should have seen that when I posted. the “>” is there, but it did not copy when I put it in. So my sequence is in the proper fasta format with >contig_10

Would the tool work for you if you give a value like 1-999999999 for the parameter Regions to put in uppercase?

Besides that, here it does seem to work (here a different version is installed) You could make an issue here: GitHub - galaxyproject/tools-iuc: Tool Shed repositories maintained by the Intergalactic Utilities Commission

1 Like