Static content does not apper in the galaxy welcome

Hi everyone,

I am having some troubles setting the static/welcome.html in my welcome page
This is what it shows:

And this is what i would like it to look like

I am going to upload the yml.

Any clue what might be going on?

Besides this, I am experiencing another issue that I suspect it might be related with the proxy (apache 2.4) and when I try to upload any files it freeze at 0%, but when I try to upload using the regular option and selecting no file it upload to 100%, any idea?

  1. List item

Thanks in advance,

Julia

Hi @VerheulJ ,

Ensure you are visiting in production mode. Changes to the welcome page only affect the production mode, not the development mode.

If the problem remains, please share your static/welcome.html file.

Pay attention that you uploaded your main config file with sensitive credentials. Delete it immediately for your safety.

Regards

3 Likes

Hi @itisAliRH,

Thanks for your quick response. Could you please tell me how can I share that file, there is no option for sharing files besides images.

About the production/develop mode, I don’t know how to change from one mode to the other, I have check already this resource but I still don’t know how.

I am editing the original github application, which works perfectly locally; the problem originates around how it communicates with the proxy. I still can not upload any file as I commented in the first post.

Thanks a lot!

Ensure you are visiting in production mode. Changes to the welcome page only affect the production mode, not the development mode.

I am also curious about this, I have not heard about this before and want to learn it of course :slightly_smiling_face:. Do you maybe mean debug: false in galaxy.yml? This is a bit documented here:Production Environments — Galaxy Project 22.09.dev0 documentation

Besides that keep in mind that the welcome page (and making changes to it) can be sensitive for cache memory. So if you are sure you changed something and do not see the change make sure to empty the cache memory of your browser. Mostly this can be done in the clear history options.

For the file upload problem I think it is hard for the forum members here to help at this point. Do you see something in the log files? Or in the apache log? If you dont have a apache log add this to the config file ErrorLog "/var/log/httpd-error.log" (just an example) of apache and restart everything.

1 Like