Tool failure with upload from disk: LOCAL INSTALLATION

Hi I am sorry about this, I seem to have broken my installation. The i) symptom first; ii) the fixes I’ve tried and then iii) the history of what I did to break it.
i) If I try and upload a file from disk (fastqsanger.gz) I get a red error straight away, it never makes it to my history and it says “tool not found or available”. (ps., also unzipped and tried the flat fastq and it was the same).
ii) To get around this I tried to re-install an upload tool, but the only one I could find was a 3rd party one that is not a clone of the original. So I downloaded and installed the 19.x upgrade. Still no go.

iii) So what did I do to it (it had been working beautifully for a year!)? I tried to install cuffdiff. This failed so I tried a couple of other dependencies manually. These failed so I uninstalled these (just those I thought-but I guess not) and then installed the whole-cummerbund package. Then Cuffdiff worked on a test set.
Then I noticed ALL my workflows that included concat (tip to toe for split lane FASTQs) were broken. I had evidently uninstalled my concat. It took quite a bit of hunting to find that again and I reinstalled a few wrong ones before getting the right one. Then I tried my corrected workflow and ONE of my source fastqsanger.gz file, already in my history threw and error. “dataset has become unusable” . So I tried to re-upload that one and… dead. It uploads (the progress bar reaches 100%) and immidiately throws an error. Tried a few other gzs and they all do this now.

Sorry this is an epic post I realise, but I thought there might be some clue as to what I did wrong.
Regards

Still fighting with this. I have now installed a new installation alongside the old one. That works fine, but I have Terrabytes of data and several histories in the old one. I have only tried running one at a time.
(1) Is there a sh.run REPAIR GALAXY function?
(2) Is there a way to copy my old objectstore.config and other necessary elements to the NEW installation to harmonise my situation.