using quast from tool-shed on local galaxy server: ModuleNotFoundError: No module named 'joblib'

I have set up a local galaxy server and installed what i need from the galaxy-toolshed, and for most parts it seems to work fine. The galaxy version i am using is 21.05.However i have problems running quast.

I have tried multiple versions of quast from the galaxy-toolshed, all of which are stated to support the galaxy version i am currently using. In all cases, quast processes fail on my galaxy server while they work on the server with the same data and quast instance.

looking at the stdout messages from the job-details it seems there are problems with finding the python module joblib.

If i understand the galaxy documentation right, galaxy should use conda by default to resolve and install dependencies (at least for my galaxy version), and accordingly i can find a _galaxy_ environment among my conda envs.
Therefore I am confused why joblib was not installed…
I have tried installing joblib into the _galaxy_ environment myself (conda install -n _galaxy_ joblib), and then restarting the galaxy server, but the problem still persists.

How can I solve this?

Welcome, @jvollme

The 21.05 release had several deprecation notices. Would you like to post back what you are using for each? The Python version might be the most important part.

I’m going to cross-post this question over to the admin chat for more help. They may reply here or there, and feel free to join the chat: You're invited to talk on Matrix

ToolShed (IUC most current):
Development history: History for tools/quast - galaxyproject/tools-iuc · GitHub
Galaxy version: May 2021 Galaxy Release (v 21.05) — Galaxy Project 23.0.1.dev0 documentation

You can install missing dependencies from the admin interface of Galaxy (Admin → Manage Dependencies). Additionally you can watch the log after you try that to see how it goes.

Hi Marten, thanks for your answer.
I already tried installing dependencies via the (Admin → Manage dependencies dialogue, but I could not seem to do much more than select “quast” and click on "install dependencies). However, as you can see in the screenshots, quast is shown as not having unresolved dependencies. And when I tick it regardless, and click on “install” nothing happens, both in the “Manage Dependencies” and the “Manage Dependencies (legacy)” dialogues.

Hi jennaj, thanks for your help. However i am not sure what you mean with “what you are using for each?”. I am sorry, i am still a newbie with galaxy servers, so i will need help finding what i should post and where to find that info…

looking at the “manage dependencies dialogues”, there seem to be unresolved python as well as samtool version dependencies for some tools that do file format conversion (Converter_cram_to_bam, ```Converter_bed_to_gff``´ etc…), which I have not needed yet though.
However for quast no unresolved dependencies are listed…

You have installed some ancient repository from 2016 that does not support conda (see the “tool shed package” text where “conda” should be. Please uninstall it and install the quast repository owned by iuc.

sorry, I think that was a misunderstanding. I installed deinstalled and reinstalled different versions of quast from the toolshed, in the hope of finding one that works. The one you saw in the screenshot was one of the older ones i tried after the newest one did not work.
Here is a screnshot of the dependency manager showing the newer version of quast. Here it also says “no unresolved dependencies”, however all quast jobs fail with the same error as mentioned above…

Could you paste or screenshot the full tool error? It would help to have some additional context that might indicate whether the conda environment is being used, what command is being run, etc.