Error: galaxy-set-metadata: command not found

I am doing the From Genes to Peaks tutorial and I am getting stuck

When I do the Intersect of promoter regions with peaks regions, I get a “An error occurred setting the metadata for this dataset” message. Inside the attributes, the info says: “/corral4/main/jobs/040/816/40816980/ line 123: galaxy-set-metadata: command not found”

Does anyone know what’s going on?

1 Like

Hi @pashadag

The output generated was malformed for some reason. It was possibly empty.

Try this:

  1. First, try a rerun for that job. The “double-circle” icon within the output dataset will bring up the original tool form, and it can be submitted again to exactly reproduce the original run. The goal is to eliminate a technical problem server-side. For any error or odd result at least one rerun is a good idea (not just when running tutorials).

  2. If the same error comes up, check which inputs are being selected on the tool form. Sometimes these get mixed up.

  3. If the correct input datasets were selected, in the right order, maybe one of those datasets has a problem.

  • Both should have the datatype assigned as bed. You can expand the dataset to view the datatype assigned, number of lines, and other details. Click on the “eye icon” to view the dataset contents – the format should match the pictures in the tutorial (not exactly – but the content should be similar).
  • You can confirm that the data is actually in bed format by redetecting the datatype. Try this for both: click on the pencil icon to reach the Edit Attributes form, go to the tab “Datatypes”, then click on the button for “Auto-detect”. The result should be bed for both – if not, something went wrong in a prior step and you’ll need to back up and maybe redo a step or two.

If you are still stuck after those checks, please generate a share link to your tutorial history and post that back here. Try to not delete any of the input or output datasets. This is how: Galaxy Training!. Be aware that this will be publicly shared – but if the history only contains the tutorial data, it shouldn’t matter and more people at this forum will be able to help you.

Let’s start there :slight_smile:

Hi jennaj,

Thank you for helping! I tried the steps you outlined but it didn’t seem to change things. Here’s a link to my shared history:

Thank you for your help,

1 Like

Update March 8, 2022

The tools in this suite are corrected at Please rerun any prior failures. The fix was a missing dependency added back at our clusters, so the tool version didn’t change.

Thanks to all who reported it!

Thanks for sharing the history. The tool itself is problematic, along with a few related tools. It will take at least a few days to investigate the root cause.

Please run the tutorial at either or instead for now.

Related recent Q&A (someone else ran into the same error today) Get flanks - error setting the metadata