Error on DADA2 merge pairs

Hi there,

I am trying to run Dada2 merge_pairs but failed always. I am following the pipeline of Dada2.
I have nine samples. Firstly, I have separated forward and reverse samples, and created a collection of each. Using the collection, I firstly run Filter&Trim -> Learn Errors -> Dada. I have no problem with this functions. For merge_pairs, I always getting always an error.

The error is:
Error in FUN(X[[i]], …) :
Non-corresponding derep-class and dada-class objects.
Calls: mergePairs -> lapply -> FUN
Execution halted

I have checked that samples have the same name. Probably something is missing. This is new to me.

Could you please help?

Thank you, CV

Hi,

I had the same problem. After I search a bit, it happens that my fastq data collection was ordered in a different way from the dada RData object list. So these were not matching. Your problem seems similar to mine. What I’ve tried and it worked was to sort the data collection before merging the paired-end files, with the “sort collection” tool. I tried to order the data collection alphabetically and this seems to have solved the problem.

I hope this helps to solve your problem,

António