Issue with dependencies at "sh run.sh" startup (Galaxy 19.01)

galaxy-local
galaxy_1901
#1

Hello, I’m new to both Python and Linux in general.
I’m currently using Ubuntu 18.04 via Windows 10.

To elaborate on the error message I received, I had already installed PIP, Python 2.7 etc.
I proceeded to execute “sh run.sh” which led me to install conda and then change versions into adaptive as described in the tutorial/guide.

However, when I execute the command I get the following message after activating virtualenv
Activating virtualenv at .venv
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: pip>=8.1 in ./.venv/lib/python2.7/site-packages (19.0.3)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Looking in indexes: https://wheels.galaxyproject.org/simple, https://pypi.python.org/simple
Requirement already satisfied: adal==1.2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 3)) (1.2.0)
Requirement already satisfied: amqp==2.3.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 4)) (2.3.2)
Requirement already satisfied: appdirs==1.4.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 5)) (1.4.3)
Requirement already satisfied: asn1crypto==0.24.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 6)) (0.24.0)
Requirement already satisfied: azure-common==1.1.14 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 7)) (1.1.14)
Requirement already satisfied: azure-cosmosdb-nspkg==2.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 8)) (2.0.2)
Requirement already satisfied: azure-cosmosdb-table==1.0.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 9)) (1.0.4)
Requirement already satisfied: azure-mgmt-compute==4.0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 10)) (4.0.1)
Requirement already satisfied: azure-mgmt-devtestlabs==2.2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 11)) (2.2.0)
Requirement already satisfied: azure-mgmt-network==2.1.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 12)) (2.1.0)
Requirement already satisfied: azure-mgmt-nspkg==3.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 13)) (3.0.2)
Requirement already satisfied: azure-mgmt-resource==2.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 14)) (2.0.0)
Requirement already satisfied: azure-mgmt-storage==2.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 15)) (2.0.0)
Requirement already satisfied: azure-nspkg==3.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 16)) (3.0.2)
Requirement already satisfied: azure-storage-blob==1.3.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 17)) (1.3.1)
Requirement already satisfied: azure-storage-common==1.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 18)) (1.4.0)
Requirement already satisfied: azure-storage-nspkg==3.1.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 19)) (3.1.0)
Requirement already satisfied: babel==2.6.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 20)) (2.6.0)
Requirement already satisfied: bagit==1.6.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 21)) (1.6.4)
Requirement already satisfied: bcrypt==3.1.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 22)) (3.1.4)
Requirement already satisfied: bdbag==1.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 23)) (1.4.1)
Requirement already satisfied: beaker==1.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 24)) (1.10.0)
Requirement already satisfied: bioblend==0.11.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 25)) (0.11.0)
Requirement already satisfied: bleach==3.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 26)) (3.0.2)
Requirement already satisfied: boltons==18.0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 27)) (18.0.1)
Requirement already satisfied: boto3==1.7.84 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 28)) (1.7.84)
Requirement already satisfied: boto==2.49.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 29)) (2.49.0)
Requirement already satisfied: botocore==1.10.84 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 30)) (1.10.84)
Requirement already satisfied: bunch==1.0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 31)) (1.0.1)
Requirement already satisfied: bx-python==0.8.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 32)) (0.8.2)
Requirement already satisfied: bz2file==0.98 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 33)) (0.98)
Requirement already satisfied: cachetools==3.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 34)) (3.0.0)
Requirement already satisfied: certifi==2018.11.29 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 35)) (2018.11.29)
Requirement already satisfied: cffi==1.11.5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 36)) (1.11.5)
Requirement already satisfied: chardet==3.0.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 37)) (3.0.4)
Requirement already satisfied: cheetah3==3.1.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 38)) (3.1.0)
Requirement already satisfied: cliff==2.14.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 39)) (2.14.0)
Requirement already satisfied: cloudauthz==0.2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 40)) (0.2.0)
Requirement already satisfied: cloudbridge==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 41)) (1.0.2)
Requirement already satisfied: cmd2==0.8.9 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 42)) (0.8.9)
Requirement already satisfied: contextlib2==0.5.5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 43)) (0.5.5)
Requirement already satisfied: cryptography==2.4.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 44)) (2.4.2)
Requirement already satisfied: debtcollector==1.20.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 45)) (1.20.0)
Requirement already satisfied: decorator==4.3.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 46)) (4.3.0)
Requirement already satisfied: deprecation==2.0.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 47)) (2.0.6)
Requirement already satisfied: dictobj==0.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 48)) (0.4)
Requirement already satisfied: docopt==0.6.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 49)) (0.6.2)
Requirement already satisfied: docutils==0.14 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 50)) (0.14)
Requirement already satisfied: dogpile.cache==0.6.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 51)) (0.6.8)
Requirement already satisfied: enum34==1.1.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 52)) (1.1.6)
Requirement already satisfied: fabric3==1.14.post1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 53)) (1.14.post1)
Requirement already satisfied: funcsigs==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 54)) (1.0.2)
Requirement already satisfied: functools32==3.2.3.post2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 55)) (3.2.3.post2)
Requirement already satisfied: future==0.17.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 56)) (0.17.1)
Requirement already satisfied: futures==3.2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 57)) (3.2.0)
Requirement already satisfied: galaxy-sequence-utils==1.1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 58)) (1.1.3)
Requirement already satisfied: gxformat2==0.8.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 59)) (0.8.1)
Requirement already satisfied: h5py==2.9.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 60)) (2.9.0)
Requirement already satisfied: idna==2.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 61)) (2.7)
Requirement already satisfied: ipaddress==1.0.22 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 62)) (1.0.22)
Requirement already satisfied: isa-rwval==0.10.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 63)) (0.10.7)
Requirement already satisfied: iso8601==0.1.12 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 64)) (0.1.12)
Requirement already satisfied: isodate==0.6.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 65)) (0.6.0)
Requirement already satisfied: jmespath==0.9.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 66)) (0.9.3)
Requirement already satisfied: jsonpatch==1.23 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 67)) (1.23)
Requirement already satisfied: jsonpointer==2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 68)) (2.0)
Requirement already satisfied: jsonschema==2.6.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 69)) (2.6.0)
Requirement already satisfied: keystoneauth1==3.11.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 70)) (3.11.1)
Requirement already satisfied: kombu==4.2.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 71)) (4.2.1)
Requirement already satisfied: mako==1.0.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 72)) (1.0.7)
Requirement already satisfied: markupsafe==1.1.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 73)) (1.1.0)
Requirement already satisfied: mercurial==3.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 74)) (3.7.3)
Requirement already satisfied: monotonic==1.5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 75)) (1.5)
Requirement already satisfied: msgpack==0.6.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 76)) (0.6.0)
Requirement already satisfied: msrest==0.5.5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 77)) (0.5.5)
Requirement already satisfied: msrestazure==0.5.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 78)) (0.5.0)
Requirement already satisfied: munch==2.3.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 79)) (2.3.2)
Requirement already satisfied: netaddr==0.7.19 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 80)) (0.7.19)
Requirement already satisfied: netifaces==0.10.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 81)) (0.10.7)
Requirement already satisfied: networkx==1.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 82)) (1.11)
Requirement already satisfied: nodeenv==1.3.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 83)) (1.3.3)
Requirement already satisfied: nose==1.3.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 84)) (1.3.7)
Requirement already satisfied: numpy==1.15.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 85)) (1.15.4)
Requirement already satisfied: oauthlib==2.1.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 86)) (2.1.0)
Requirement already satisfied: openstacksdk==0.17.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 87)) (0.17.0)
Requirement already satisfied: os-client-config==1.31.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 88)) (1.31.2)
Requirement already satisfied: os-service-types==1.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 89)) (1.4.0)
Requirement already satisfied: osc-lib==1.11.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 90)) (1.11.1)
Requirement already satisfied: oslo.config==6.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 91)) (6.7.0)
Requirement already satisfied: oslo.context==2.22.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 92)) (2.22.0)
Requirement already satisfied: oslo.i18n==3.23.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 93)) (3.23.0)
Requirement already satisfied: oslo.log==3.42.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 94)) (3.42.0)
Requirement already satisfied: oslo.serialization==2.28.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 95)) (2.28.1)
Requirement already satisfied: oslo.utils==3.38.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 96)) (3.38.0)
Requirement already satisfied: packaging==18.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 97)) (18.0)
Requirement already satisfied: paramiko==2.4.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 98)) (2.4.2)
Requirement already satisfied: parsley==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 99)) (1.3)
Requirement already satisfied: paste==3.0.5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 100)) (3.0.5)
Requirement already satisfied: pastedeploy==2.0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 101)) (2.0.1)
Requirement already satisfied: pastescript==3.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 102)) (3.0.0)
Requirement already satisfied: pbr==5.1.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 103)) (5.1.1)
Requirement already satisfied: prettytable==0.7.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 104)) (0.7.2)
Requirement already satisfied: psutil==5.4.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 105)) (5.4.8)
Requirement already satisfied: pulsar-galaxy-lib==0.8.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 106)) (0.8.3)
Requirement already satisfied: pyasn1==0.4.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 107)) (0.4.4)
Requirement already satisfied: pycparser==2.19 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 108)) (2.19)
Requirement already satisfied: pycryptodome==3.7.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 109)) (3.7.2)
Requirement already satisfied: pycryptodomex==3.7.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 110)) (3.7.2)
Requirement already satisfied: pyinotify==0.9.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 111)) (0.9.6)
Requirement already satisfied: pyjwkest==1.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 112)) (1.4.0)
Requirement already satisfied: pyjwt==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 113)) (1.7.0)
Requirement already satisfied: pykwalify==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 114)) (1.7.0)
Requirement already satisfied: pynacl==1.3.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 115)) (1.3.0)
Requirement already satisfied: pyopenssl==18.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 116)) (18.0.0)
Requirement already satisfied: pyparsing==2.3.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 117)) (2.3.0)
Requirement already satisfied: pyperclip==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 118)) (1.7.0)
Requirement already satisfied: pysam==0.15.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 119)) (0.15.1)
Requirement already satisfied: pysftp==0.2.9 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 120)) (0.2.9)
Requirement already satisfied: python-cinderclient==4.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 121)) (4.0.0)
Requirement already satisfied: python-dateutil==2.7.5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 122)) (2.7.5)
Requirement already satisfied: python-genomespaceclient==1.1.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 123)) (1.1.0)
Requirement already satisfied: python-glanceclient==2.12.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 124)) (2.12.0)
Requirement already satisfied: python-keystoneclient==3.17.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 125)) (3.17.0)
Requirement already satisfied: python-neutronclient==6.9.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 126)) (6.9.0)
Requirement already satisfied: python-novaclient==11.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 127)) (11.0.0)
Requirement already satisfied: python-openid==2.2.5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 128)) (2.2.5)
Requirement already satisfied: python-swiftclient==3.6.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 129)) (3.6.0)
Requirement already satisfied: pytz==2018.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 130)) (2018.7)
Requirement already satisfied: pyyaml==3.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 131)) (3.13)
Requirement already satisfied: repoze.lru==0.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 132)) (0.7)
Requirement already satisfied: requests-oauthlib==1.0.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 133)) (1.0.0)
Requirement already satisfied: requests-toolbelt==0.8.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 134)) (0.8.0)
Requirement already satisfied: requests==2.20.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 135)) (2.20.1)
Requirement already satisfied: requestsexceptions==1.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 136)) (1.4.0)
Requirement already satisfied: rfc3986==1.2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 137)) (1.2.0)
Requirement already satisfied: routes==2.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 138)) (2.4.1)
Requirement already satisfied: s3transfer==0.1.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 139)) (0.1.13)
Requirement already satisfied: simplejson==3.16.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 140)) (3.16.0)
Requirement already satisfied: six==1.11.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 141)) (1.11.0)
Requirement already satisfied: social-auth-core[openidconnect]==1.5.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 142)) (1.5.0)
Requirement already satisfied: sqlalchemy-migrate==0.12.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 143)) (0.12.0)
Requirement already satisfied: sqlalchemy-utils==0.33.9 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 144)) (0.33.9)
Requirement already satisfied: sqlalchemy==1.2.14 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 145)) (1.2.14)
Requirement already satisfied: sqlparse==0.2.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 146)) (0.2.4)
Requirement already satisfied: stevedore==1.30.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 147)) (1.30.0)
Requirement already satisfied: subprocess32==3.5.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 148)) (3.5.3)
Requirement already satisfied: svgwrite==1.2.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 149)) (1.2.1)
Requirement already satisfied: tempita==0.5.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 150)) (0.5.2)
Requirement already satisfied: tenacity==4.12.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 151)) (4.12.0)
Requirement already satisfied: typing==3.6.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 152)) (3.6.6)
Requirement already satisfied: tzlocal==1.5.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 153)) (1.5.1)
Requirement already satisfied: unicodecsv==0.14.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 154)) (0.14.1)
Requirement already satisfied: urllib3==1.24.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 155)) (1.24.1)
Requirement already satisfied: uwsgi==2.0.17.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 156)) (2.0.17.1)
Requirement already satisfied: vine==1.1.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 157)) (1.1.4)
Requirement already satisfied: warlock==1.3.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 158)) (1.3.0)
Requirement already satisfied: wcwidth==0.1.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 159)) (0.1.7)
Requirement already satisfied: webencodings==0.5.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 160)) (0.5.1)
Requirement already satisfied: webob==1.8.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 161)) (1.8.4)
Requirement already satisfied: whoosh==2.7.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 162)) (2.7.4)
Requirement already satisfied: wrapt==1.10.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 163)) (1.10.11)
Traceback (most recent call last):
File “”, line 1, in
File “/home/pcf/galaxy/lib/galaxy/dependencies/init.py”, line 12, in
from galaxy.containers import parse_containers_config
File “/home/pcf/galaxy/lib/galaxy/containers/init.py”, line 24, in
from galaxy.exceptions import ContainerCLIError
File “/home/pcf/galaxy/lib/galaxy/exceptions/init.py”, line 19, in
from …exceptions import error_codes
File “/home/pcf/galaxy/lib/galaxy/exceptions/error_codes.py”, line 9, in
from galaxy.util import unicodify
File “/home/pcf/galaxy/lib/galaxy/util/init.py”, line 38, in
from boltons.iterutils import (
File “/home/pcf/galaxy/.venv/local/lib/python2.7/site-packages/boltons/iterutils.py”, line 1155, in
guid_iter = GUIDerator()
File “/home/pcf/galaxy/.venv/local/lib/python2.7/site-packages/boltons/iterutils.py”, line 1074, in init
self.reseed()
File “/home/pcf/galaxy/.venv/local/lib/python2.7/site-packages/boltons/iterutils.py”, line 1082, in reseed
‘hex_codec’).decode(‘ascii’)])
UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xec in position 0: ordinal not in range(128)

Any help would be greatly appreciated!