pam login issue

I’m having an issue getting PAM based user logins to work in v20.01. The problem has to do with Galaxy not having sufficient permissions to create a new user account folder.

For some unknown reason, it wants to append our org’s domain to the user folder. This is unnecessary because the correctly named username folder (sans suffix) already exists in /home. I’ve tested manually creating the fully qualified folder prior to login and it works.


galaxy.webapps.galaxy.controllers.user DEBUG 2020-05-29 13:15:34,638 [p:93475,w:1,m:0] [uWSGIWorker1Core2] /hpc/software/installed/galaxy/20.01/config/auth_conf.xml
galaxy.auth.providers.pam_auth DEBUG 2020-05-29 13:15:34,639 [p:93475,w:1,m:0] [uWSGIWorker1Core2] use username: True use email False email None username test.user
galaxy.auth.providers.pam_auth DEBUG 2020-05-29 13:15:34,639 [p:93475,w:1,m:0] [uWSGIWorker1Core2] PAM auth: will use external helper: False
galaxy.auth.providers.pam_auth DEBUG 2020-05-29 13:15:34,951 [p:93475,w:1,m:0] [uWSGIWorker1Core2] PAM authentication successful for test.user
galaxy.auth.util DEBUG 2020-05-29 13:15:34,955 [p:93475,w:1,m:0] [uWSGIWorker1Core2] Email:, auto-register with username: test.user
galaxy.web.framework.decorators ERROR 2020-05-29 13:15:35,102 [p:93475,w:1,m:0] [uWSGIWorker1Core2] Uncaught exception in exposed API method:
Traceback (most recent call last):
File “lib/galaxy/web/framework/”, line 282, in decorator
rval = func(self, trans, *args, **kwargs)
File “lib/galaxy/webapps/galaxy/controllers/”, line 122, in login
return self.__validate_login(trans, payload, **kwd)
File “lib/galaxy/webapps/galaxy/controllers/”, line 147, in __validate_login
message, user = self.__autoregistration(trans, login, password)
File “lib/galaxy/webapps/galaxy/controllers/”, line 105, in __autoregistration
File “lib/galaxy/web/framework/”, line 720, in handle_user_login
File “lib/galaxy/web/framework/”, line 665, in user_checks
File “lib/galaxy/web/framework/”, line 657, in check_user_library_import_dir
File “lib/galaxy/util/path/”, line 114, in safe_makedirs
File “/hpc/software/installed/galaxy/20.01/.venv/lib64/python3.6/”, line 220, in makedirs
mkdir(name, mode)
PermissionError: [Errno 13] Permission denied: ‘/home/’


<?xml version=“1.0”?>


domains =
config_file_version = 2
services = nss, pam, sudo

ad_domain =
krb5_realm = DOMAIN.COM
realmd_tags = manages-system joined-with-samba
cache_credentials = True
id_provider = ad
krb5_store_password_if_offline = True
default_shell = /bin/bash
ldap_sasl_authid = galaxy1$
ldap_id_mapping = False
use_fully_qualified_names = False
fallback_homedir = /home/%u
access_provider = simple
simple_allow_groups = Group1, Group2

Anyone able to point me in the right direction?


Solution: Disable all user_library_import settings.