Stacks : de novo map ending in "unable to finish job"

Hi everyone!

I have used the Stacks series a few times before but now have an error that I can’t seem to get around.

I did the demultiplexing via Stacks V2.55, having three enzymes I activated the option “Disable checking if the RAD site is intact” and only entered 2 of them (one frequent and one rare cutter). For the rest, I used the same parameters as I used before. The demultiplexing went fine.

Now, as for the assembly, the de novo wrapper always ends on “Unable to finish job”. Funny enough, all the files that are not lists (the summary statistics, the logs) are available and can even be downloaded. I can see the list of the loci and where there are consensus, for example. But as for the lists, they just do not exist, so I don’t have the catalog of loci’s actual sequences for example, which is quite a bother.

It took between one day and a week for the data to stop running. I have PE data, 2 species for which I have 14 and 10 individuals. I used only the default options.

Anybody could have an idea of the problem?

Thank you in advance.

Hi @Joelle99

Partial outputs could be for a few different reasons… it could be a technical problem or the tool ran out of resources during execution.

Using default settings may be the problem since the original data wasn’t quality filtered as stringently as your prior runs (if I am understanding correctly!). Meaning, you may need to be stricter at this step to get a successful result. Tutorial (older version of the tool suite, but still helpful): RAD-Seq de-novo data analysis

So, please try this:

  1. Send in a bug report from the current error and include a link to this help forum post in the comments. The EU team can review it closer with that context/information. Try not to delete any datasets yet.

  2. Startup another rerun exactly the same as originally ran in that same history. Might as well get that started since it took several days to process the first time. If there was some transient server issue, a rerun is usually the solution.

  3. Next, review the assembly options, and consider making the settings stricter. You might want to try a few different combinations. The tutorial above has some examples of that, plus links to the tool suite documentation and forum (also at the bottom of the tool forms).

Let’s start there :slight_smile: It is evening in the EU right now, but this covers the first steps in troubleshooting. You can always cancel jobs that aren’t needed once you get more feedback. Perhaps the tool needs more resources the EU admins can allocate, or there was some cluster problem, or maybe the job as-is is actually one that will never run completely as it is currently set up and tuning assembly parameters are needed.

Related Q&A Stacks: 3 Rad-seq Demultiplexing

Hi there, and thank you for your return! I have already completed #1 and #2, but I’ll now try like you said to diminuish the tool’s burden by being more strict in the options. Thank you!

To follow up a little bit, I have yet to receive any news from the support. On the other hand, I tried multiple solutions with sadly no positive results. I have tried reducing the number of samples by using only forward reads in my paired-end experiment, as well as choosing options that would be stricter. @jennaj, should I filled another ticket for the support?

Thank you.


If anyone shares this problem, I “solved” it by using not the V2 of Stacks but the version 1.46, which apparently works for this type of situation.