16S microbial analysis tutorial

Hi all, I noticed that in the 16S microbial analysis tutorial

That the zenodo links for importing the data each have a space in front of them, which prevents them being detected as links during import. Has anyone else had this problem?

1 Like

Hi @Michael_Thon

Yes, I’ve seen that in other tutorials, and fixed it up. Was a simple editing mistake by whoever last touched that view.

If you want … you could edit that file. It will start up a pull-request to fix it. All can be done through the web browser directly from the tutorial page. You don’t need to know anything special about Github to do that. Look in the masthead for the “edit” button. Community contributions are welcome!

Or, let me know and I can do it. :slight_smile:

Hi @jennaj
I checked the markdown file on github but the links to the data files seem to be fine. Maybe someone else has fixed it but the changes haven’t been published? Maybe you could have a look?
Thanks!

Will do. Now I’m wondering if that was mine from about a year ago … :upside_down_face:

Update:

I was able to confirm … the md file is fine. The site builds itself so I’m not sure what is going on! Decided to open a ticket so the administrators can review more and fix it. Spaces showing up for Zenodo links but absent from md · Issue #4853 · galaxyproject/training-material · GitHub

Thanks for the follow up!

I’m afraid the spacing was indeed ever so slightly off in a way that’s very difficult to see at a glance. It’ll be fixed in this pr:

To explain how it’s happening, here’s a small snippet of the current state.

To be clear I don’t expect anyone to see this when reviewing or editing, it’s extremely non-obvious. (but I a maintainer of a platform with a quarter million lines of markdown).

>    - Past
>
>     ```
>     https
>     https

it’s slightly clearer without the newline.

>    - Past
>     ```
>     https
>     https

Note how the first backtick ` lines up with the space between - and Past, this is, surprisingly, wrong. It must be aligned with the text of the Past. The - list item requires 1 space of indentation after the - and 2 spaces on a subsequent line (i.e. aligned with the first) to properly be detected as “part of this list item”

Instead it was marked as part of the parent non-list blockquote text. It’s indented by 5 spaces relative to that, 5 is the key number as indentation past 4 triggers a “space indented code block” (as opposed to a fenced code block).

Space indented code blocks are sometimes regarded as a mistake. No one uses them, fenced code blocks are far more popular, and they’re usually just the cause of issues.

So, 4 spaces to trigger the code blcok, and 1 space to break all of your copy pasting :frowning:

On the GTN side I don’t think we have a good way to prevent this, but I can explore some things in the future. It’s more or less impossible to look at the markdown and infer/validate what the user meant so it’s incredibly difficult to prevent it at that level without digging deeply into the internals of our markdown processor. Perhaps we can check code blocks on the output side for consistently unexpected spacing but i’m not sure how reliable that will be.

1 Like