CUTADAPT GALAXY TUTORIAL_inserting adaptor sequence?

Hello, I am new to RNA-seq analysis and is following some of the tutorials to analysing my RNA sequences for DGE analysis. I noticed that one of the tutorials using Cutadapt inserts adaptor sequence in "Read 1 Options’’, where as the another tutorial does not, which makes me a bit confused. Is there any reason to do it in different ways ?


  • In “Read 1 Options” :
    • In “3’ (End) Adapters” :
      • Click on “Insert 3’ (End) Adapters” :
      • In “1: 3’ (End) Adapters” :
        • param-select “Source” : Enter custom sequence
          • param-text “Enter custom 3’ adapter name (Optional)” : Illumina
          • param-text “Enter custom 3’ adapter sequence” : AGATCGGAAGAGCACACGTCTGAACTCCAGTCAC


ith the following parameters to trim low quality sequences:

  • “Single-end or Paired-end reads?” : Paired-end
    • param-files “FASTQ/A file #1 : both _1 fastqsanger datasets (multiple datasets)
    • param-files “FASTQ/A file #2 : both _2 fastqsanger datasets (multiple datasets)The order is important here!
  • In “Filter Options”
    • “Minimum length” : 20
  • In “Read Modification Options”
    • “Quality cutoff” : 20
  • In “Output Options”
    • “Report” : Yes
      I tried both methods (1) inserting adaptor sequence and (2) not providing any specific information for the adaptor, and got different results on the MultiQC of the trimmed reads.

The ‘Cutadapt_mqc-generalstats-cutadapt-percent_trimmed’ is twice (around 1.4) when I provide the adaptor sequence as compared to when no adaptor sequence is specified (around 0.8 to 0.9 )as a parameter. Wouldn’t this have an impact on downstream analysis?

Many thanks,

I think this is the key sentence:

ith the following parameters to trim low quality sequences:

In tutorial 1 it looks like you do primer/adapter trimming en in tutorial 2 you do quality trimming. I think you are the one that knows the data and can make the best decision. Did you already used FastQC before trimming?

1 Like

Thank you for the reply. I did the FastQC before trimming. Although the fastQC report did not show that there is Illumina adaptors present, I did a quick blast with the universal Illumina adaptor sequence and found that adaptors are acutually present in the reads. So, I decided to proceed with the Cutadapt, providing Illumina adaptor sequences in the parameter both the paired reads.

Many thanks,