Error occured during the CAMERA step

Hello to everybody!
In these days I tried to use W4M but always with the same final error.
I processed some files, step by step, and everything was ok! When I’ve tried to submit the last RData file obtained from “fillPeaks step” to “xcms process history” step and to “CAMERA annotate step” and some errors were happened

Error in chromPeaks(from)[, “is_filled”] : subscript out of bounds
Calls: getxcmsSetObject
Execution halted

All prior steps are “green”, done in the correct sequence, and no errors occurred!

Thank you.


1 Like

Maybe try to report here

1 Like

I try it! But today I have many problems to connect with these webpages
Thank you Matthias.

Hi here,

I’m the developer of the CAMERA wrapper for Galaxy (don’t confuse with the developer of CAMERA itself) and also administrator of the workflow4metabolomics instances : and

I’m arriving on this thread because we have almost the same issue with another tool " metams_runGC:stuck_out_tongue:
Error in chromPeaks(from)[, "is_filled"] : subscript out of bounds

Still an mystery at this point.

Can you discribe your problems with the instance?

Hi Gildas,
the truth is that I don’t know what’s happened! I carried out all the steps and all were successful. When I processed the CAMERA.annotate happened this error.
I re-processed all study with small changes in some parameter and a curious thing happened! This time I managed to process the CAMERA.annotate step (green!) but inside there wasn’t information (0 bytes)!

Galaxy CAMERA Annotate|366x500

Can you click on the little (i) and check the stdout and stderr links?

Just to let you know, I’m exchanging with one of the XCMS author:

@Manu-MF We are progressing on this issue.
Can you tell me which versions of the wrappers you are using?

  • xcms fillPeaks:
  • CAMERA annotate:

Thanks for your patience!

Yes, thank you so much! But I unfortunately had to delete that History because of “memory problems”. And I didn’t manage to send you the error report because here I can’t upload PDF file.

However the versions were:
xcms fillPeaks: Galaxy Version 3.6.1+galaxy0
CAMERA annotate: Galaxy Version 2.2.6+camera1.42.0-galaxy1