I deployed GVL galaxy via the instructions to deploy thru GVL into AWS, enabled galaxy.yml....site is now broken

I enabled galaxy.yml (cp’ing from galaxy.yml.sample so I could give a datascientist admin rights to this instance) and ever since I did that, nothing else the site is no longer accessible externally. I edited the http statement (changing it from the self assigned to and it would STILL run the site on, The only thing that worked was putting the in quotes…then the output I would see when running the run.sh script would show what I was trying to edit. That still didnt work so I decided to make the IP address what the ACTUAL ip address is (not ideal since I either have to pick the internally facing IP or the external IP) but the site is still not accessible outside of the localhost. The port is open on our AWS security group. UFW is not running (This is a Ubuntu 16.04 machine).

Again this host was working exactly as it was supposed (minus the instructions either being wrong or missing on the site but thats a whole other issue) until I copied to the galaxy.yml file. I cant even revert. I tried deleting the file in the hopes I could reverse this issue and its STILL exhibiting the same problem. This is seems like a stupid problem but I have burned all day on it and gotten no where

Please help

Also want to add I cloned a git repo fo the latest code for the site to a different directory and tried it with that instance and essentially got the same result.

Hi @Aech1977

You should contact the GVL development/support team directly about this. From my understanding, administrators can be set through the GUI or by modifying the galaxy.yml (plus a restart) in GVL’s version of Cloudman, but I could be mistaken. There have been quite a few changes and yes, the documentation is outdated in a few places. There is a lot of activity around upgraded cloud solutions for Galaxy.

The contact information is on the Cloudlanch website when the “GVL” option is moused over. Also screenshotted below here so you don’t have to hunt for it. It points to the Galaxy AU server.


At that server, scroll to the bottom to find the actual contact email:

I’m also going to ping a few people working in this area to see if they can help more here: @Slugger70 @enis @nuwang

One of these routes should work to help solve the hosting problems.

I noticed that after I had already copied the galaxy.yml out. I tried to just remove the file but like I said cloudmanager is broken and I dont know how to fix that aspect of it. I’ve spent more time then it was worth to try and fix this.

Hi @Aech1977,

This version of cloudman doesn’t support galaxy.yml, as you’ve discovered by now. There is an alpha version of the GVL that does, but depending on your stability requirements, you may or may not want to move to that. How did you restart galaxy after replacing galaxy.yml? Through the cloudman UI or by hand? In any case, if you delete galaxy.yml and reboot the server, it should work as expected. If it still doesn’t work, can you provide galaxy logs (/mnt/galaxy/galaxy-app/) and cloudman logs (/var/log/cloudman/), and we can try to figure out what might be going wrong.

1 Like

I got the green light to redo the host. I just went ahead and did that. Thanks for being willing to help.

1 Like