Problems Installing Mothur Suite on MAC OSX: Result > dependencies are not available through Bioconda

tool-install
galaxy-local
mothur
#1

Hi,

I’m trying to install the mothur suite on my local Galaxy (newest version), but I’m running into troubles. When I attempt to install it, my Galaxy stops working. Then I tried to install a single components through the repository, but it has troubles to install the mothur (1.39) dependency. In the terminal I’m getting this message:

PackageNotFoundError: Packages missing in current channels:

  • mothur

We have searched for the packages in the following channels:

Please help me, I do not want to be mothurless any longer.

#2

Hi, I asked for some feedback/help from the tool authors at the IUC Gitter chat, feel free to join the chat there, or they might get back here: https://gitter.im/galaxy-iuc/iuc?at=5c8a830fd3b35423cbbaa805

Just to clarify a few items that will help with troubleshooting:

1 Like
#3

I was running Galaxy 19.04, but I tried it now with the stable branch of the 19.01 Galaxy release with the same result. Both of them were a new install. I’ve tried to install other tools (with dependencies) and for them it worked.
I’m running Galaxy inside a virtualenv. I guess I use the default dependency resolvers, because I haven’t changed the settings.
I will check out gitter. Thank you very much for your help.

1 Like
#4

If someone has the same issue: I was trying to install it on my mac, while mothur is not available for macOS in Bioconda

1 Like
#5

Thanks for posting that information back to the thread!

I saw your chat about this at Gitter, and the end result was certainly unexpected! I’m going to mark your reply as the solution so others that run into the same problem can find the remarks.