Python versions

Just to confirm: Galaxy does not need Python 2.7, right? It will work fine with 3.6/3.7?

Just because I read this on so many places…

Yes, recent Galaxy versions work fine with 3.5+ Galaxy (19.09 or newer). We still occasionally discover issues with python 3 support as more people start using Galaxy on python 3, but I would advise you to update.

There is currently a bug with uwsgi that prevents threading on python > 3.7.1, so your best bet now would be 3.6