The Rstudio on Galaxy: I cannot install the Seurat package

I want to use the Rstudio function on Galaxy. However, I cannot install the Seurat package which I will use for many tasks (it cannot run just by the seurat tool) . I find it may cause by the “png” package which need the development package. I think the " sudo yum install libpng-devel" may solve this on CentOS.

1 Like

Hi @Midsummer

Are you working at a public Galaxy server? Which one? (URL)

If you are trying to set up Rstudio at your own Galaxy server, have you seen the instruction here for installing the package? seurat/install.Rmd at master · satijalab/seurat · GitHub

Here is the URL: Galaxy | Europe (usegalaxy.eu)

1 Like

Hi @Midsummer

Ok, thanks. That server has Seurat in the list found in the lower right panel in the default view (tab into “Packages”). Select and install it.

That was I done, but it cannot be installed(shows the error : need the package ‘png’).

1 Like

HI @Midsummer

Ok, I can reproduce the problem. There is a compiling error

ERROR: dependencies ‘leiden’, ‘png’, ‘reticulate’ are not available for package ‘Seurat’
* removing ‘/usr/local/lib/R/site-library/Seurat’
Warning in install.packages :
  installation of package ‘Seurat’ had non-zero exit status

Posts here https://community.rstudio.com/ suggests there are some known problems with that package itself.

To get around it, I tried installing older binaries, but that only resulted in time-outs.

Let’s get some help from the Galaxy developers who worked on getting Rstudio deployed within Galaxy. I can’t even find the version of Seurat that was in the list of pre-compiled packages today (was there yesterday! at both usegalaxy.org and usegalaxy.eu) – maybe it can be added again or I’m using the wrong command/source. Ping @hxr @bjoern.gruening

Thanks for following up!

Hi @Midsummer @jennaj

This is a known issue and has been since RStudio was available. The current version of the RStudio container doesn’t include all dependencies you might want, and, unlike jupyter cannot run as root. So you cannot easily install missing dependencies.

In a future version of the container we hope to switch to conda which would alleviate this, but for now I’m afraid there isn’t an easy solution. We can add new dependencies to the base RStudio container of course but this takes a while to get deployed everywhere.

2 Likes

Thank you very much for the reply.
But I tried at the Rstudio cloud and it can work. Hopefully, we can get there also.

@Midsummer can you please try today? I have created a version with conda enabled.
So you can install any of the 5000 conda packages, including seurat now via the commandline.

1 Like

Thank you very much! It works.

One more thing, when I use the gx_put() , gx_get() or gx_save().
I got the errors like: “sh: 1: /usr/local/bin/put: not found” “sh: 1: /usr/local/bin/get: not found”
Do you know why?

@Midsummer can you please try it again? Do you see any other problems?

The 'Seurat ’ is already installed, it can works. But when I try to install the “glmGamPoi” it failed which can help the seurat run the SCTransform .