Cannot select column in Count tool in Workflow

I tried to add the Count tool to Workflow. The problem is I cannot pre-select the column (to be counted) in the workflow.

I have tried typing in “c3” or “column: 3” but they are not work. After executed the workflow, the result show 0 count and say “Illegal column specification.”

Selecting columns outside Workflow is fine.

Is there any way I can specify column in Workflow?

The tool works correctly in the workflow for me if I enter c1. Are you sure the input data has three columns?

c3 or just 3 should work assuming a recent version of Galaxy (and the input dataset in question having at least 3 columns). which galaxy server are you working on, and can you send a bug report using the bug icon?

Thank you for both of your response.

I suspected that when I used the tool directly (not using the tool via Workflow), the Count tool has to recognize or read the data first so it can know how many columns there are in the data. When i open the tool and not selecting any data, it showed this

When i entered my data to be analysed, it showed something like this

Or this

If this is the case, does it mean that this tool could not work in Workflow? because it cannot know beforehand how many columns are going to be in the data? (My SAM data is generated in the middle of my Workflow)

Any workaround for this issue?
Thank you

c3 or 3 is working fine when I used it directly with my same data, but not through Workflow.

But even when use directly, I have to choose the column from a list anyway. When I enter “3”, it showed this


1 Like


I created a small workflow replicating your descriptions, and it seems to work whether the SAM header is included or not. The output with a header is noisier. Maybe this will help? Both the history and the workflow can be imported, reviewed, and compared to what you have now. You might also want to apply the “workflow metadata reset” below – now while troubleshooting this tool, then later as needed.

Tip: Workflow metadata “reset”: When upstream inputs or steps have certain changes applied during editing (data structure, metadata), it can help to disconnect all of the “noodles” between downstream steps, then to reconnect again in the order of execution.

Hi @RK46 I’m wonder if more is going on.

BAM-to-Sam will by default produce a SAM file with headers and that will be assigned the datatype sam.

Count is expecting a tabular datatype with all rows containing the same number of columns.

Are you adjusting the first tool to output what the second can read? If not, that may be the root problem.