Workflow Optional Input Problem ("simple-inputs")

I made a workflow with an optional simple input, called filter. When I run the workflow using an API call, I get an error message that an input step is missing.

Why this is happening?

Thank you in advance for your help.

PS. This is the error, I got from Galaxy.

“errMsg”: “Workflow cannot be run because an expected input step ‘93’ has no input dataset.”,
“errCode”: “0”

1 Like

Hi @kkech

If you added in any new inputs after the downstream tools were connected, sometimes problems can be resolved by disconnecting the noodles then reconnecting them. Start from the inputs and connect the tools in the order of execution.

There are some metadata settings that occur when tools are connected. It seems like that is what is going wrong in your case, so please give that a try first, for the quickest resolution.

There are no known issues with using simple-inputs right now, but if you are still having problems, share more details. Where are you working (public server? URL? your own server?). What tool is failing, name and version (cannot see the name in your graphic)? Does the workflow execute correctly when run directly from the web browser as well, or just when executing it via the API?

We might ask for you to share a link to the workflow, or more details about your API query, if the issue cannot be reproduced, but that can be done privately if you prefer.


Hi @jennaj!

Thank you for helping.

The problem occurs only when I run the workflow through an API call with no argument for the optional field. When I run the workflow through the web browser works as expected. I am using the POST workflows/{workflowId}/invocations.

I am working on a private server. Can you send me a private message in order to send you more information?

Thank you very much!

1 Like

In my experience, the optional setting on inputs is broken.
I think if you reload the workflow editor and check the input it automatically resets the optional field to ‘no’.


Unfortunately optional workflow inputs do not work yet. Ongoing work is in

Right now you can only set this to runtime parameters in the tool, and a user would need to go to all steps with optional values and set them. The UI builds up these parameters before submission, which isn’t easy to recapitulate in the API, and hopefully we will eliminate this soon.

1 Like

@innovate-invent @mvdbeek

Thank for your answers!