Connection timed out error while running data_manager_fetch_genome_dbkeys_all_fasta

Dear all,

I have a local Galaxy v 21.09 installed on a server and would like to build a reference genome using data_manager_fetch_genome_dbkeys_all_fasta by following the reference at Create DBKey and Reference Genome. I got the connection timed out error as listed at the bottom of this message.

I then tried to edit galaxy.yml by following Tool Development from bright idea to toolshed - Data Managers - Galaxy Community Hub to add the following options:

Data manager configuration options

enable_data_manager_user_view = True
data_manager_config_file = data_manager_conf.xml
shed_data_manager_config_file = shed_data_manager_conf.xml
galaxy_data_manager_data_path = tool-data

I still got the same error after the configuration. Thank you for your generous help.


Here are the input parameters:

Use existing dbkey or create a new one.: existing
DBKEY to assign to data: hg38
Name of sequence: Empty.
ID for sequence: Empty.
Choose the source for the reference genome: ucsc
UCSC’s DBKEY for source FASTA: hg38
Sort by chromosome name: as_is

Error message from data_manager_fetch_genome_dbkeys_all_fasta:

Traceback (most recent call last):
File “/home/galaxy/shed_tools/”, line 497, in
File “/home/galaxy/shed_tools/”, line 478, in main
File “/home/galaxy/shed_tools/”, line 300, in download_from_ucsc
url = _get_ucsc_download_address(params, dbkey)
File “/home/galaxy/shed_tools/”, line 260, in _get_ucsc_download_address
path_contents = _get_files_in_ftp_path(ftp, ucsc_path)
File “/home/galaxy/shed_tools/”, line 65, in _get_files_in_ftp_path
ftp.retrlines(‘MLSD %s’ % (path), path_contents.append)
File “/home/galaxy/galaxy/database/dependencies/_conda/envs/__python@3.7/lib/python3.7/”, line 475, in retrlines
with self.transfercmd(cmd) as conn,
File “/home/galaxy/galaxy/database/dependencies/_conda/envs/__python@3.7/lib/python3.7/”, line 406, in transfercmd
return self.ntransfercmd(cmd, rest)[0]
File “/home/galaxy/galaxy/database/dependencies/_conda/envs/__python@3.7/lib/python3.7/”, line 368, in ntransfercmd
File “/home/galaxy/galaxy/database/dependencies/_conda/envs/__python@3.7/lib/python3.7/”, line 728, in create_connection
raise err
File “/home/galaxy/galaxy/database/dependencies/_conda/envs/__python@3.7/lib/python3.7/”, line 716, in create_connection
TimeoutError: [Errno 110] Connection timed out

1 Like

Hi @syliang18

The UCSC downloads site was likely busy when you ran the query. Have you tried again yet?

Tutorials: Galaxy Training! If your goal is to access the same genomes that are indexed at usegalaxy.* public servers, then you could mount the same pre-computed index data to your server.

Docs: Data managers — Galaxy Project 21.09.1.dev0 documentation

Hope that helps or that you have already solved the problem! :slight_smile: