cwltool and pyparsing version conflict in v22.01

Hi, All. When attempting to update to v22.01 using ansible, we seem to be running into a version conflict between the versions of cwltool and pyparsing requested in galaxy/server/lib/galaxy/dependencies/pinned-requirements.txt. The exact error is:

The conflict is caused by:
The user requested pyparsing==3.0.7
cwltool 3.1.20211107152837 depends on pyparsing!=3.0.2
cwltool 3.1.20211107152837 depends on pyparsing<3; python_version <= "3.6"

Any suggestions for resolving this would be greatly appreciated.

Many thanks,
Devin

Hi Devin,
what Python version are you using? You need at least Python 3.7 for Galaxy 22.01.

1 Like

Thanks! I was using 3.6.8 - the default python3 on EL7. It looks like everything is working after switching to a local install of 3.7.6.

For what it’s worth, I also tried 3.8.11 from software collections. This appeared to fail in the docker setup with ‘getspnam(): name not found’.

Thanks again,
Devin