Download issue for file larger than 1GB

Our local galaxy production server is facing issue of downloading file larger than 1 GB.
Galaxy version is 20.01
we have tried downloading through wget | curl options and tried to change nginx parameters.
Please assist.

Did you also used the try x-accel-redirect option?

Also take a look at a solution I have posted earlier:

Thanks for the help.

Change in x-accel-redirect option is not enough.
proxy_max_temp_file_size is also playin a role as said by dannon.


Hi all – this Q&A has some alternatives:

Also please see:

ping @nate @mvdbeek – can you help out? We made changes on but this person is using a local install.