fastqc command not found

Hello,
I’m IT support trying to setup Galaxy for a faculty member. I have 20.09 installed on CentOS 7 Virtual server. The site looks to be functioning correctly. I have been able to install toolsets through the Admin Tool Shed. However, for some reason, the fastqc is not able to run. stderr give this: /srv/galaxy/database/jobs_directory/000/6/tool_script.sh: line 9: fastqc: command not found
I ran a find for fastqc and this is the output:
[galaxy@galaxy1 galaxy]$ find . -name fastqc -print
./database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc
./database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc/e7b2202befea/fastqc
./src/galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc
./src/galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc/e7b2202befea/fastqc

Did fastqc get installed correctly? What steps can I do to troubleshoot this?
Thanks…

@cjkeist please check if you have a conda installation somewhere. By default, if you have not configured Galaxy otherwise, Galaxy will resolve dependencies for tool with the Conda package manager. So there should be a conda environment somewhere for fastqc.

Thank you for your reply. I installed conda via pip and restarted galaxy. Still getting the same error after uninstalling and re-installing fastqc.
Version fastqc: Revision 19 v.0.72
Python: 3.6.12

find . -name fastqc -print
./src/galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc
./src/galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc/e7b2202befea/fastqc

Looks like pip install of conda was not the correct way as I found via command line running conda. So pip uninstall conda and then installed conda through pyenv. So now have the following set for the Galaxy environment:
[galaxy@galaxy1 galaxy]$ pyenv versions
system

  • 3.6.12 (set by /home/galaxy/.pyenv/version)
  • anaconda3-5.3.1 (set by /home/galaxy/.pyenv/version)
    Re-running test however still getting the fastqc command not found error :frowning:

Tried to resolve dependencies but seeing the following in galaxy.log file. Permission denied, but I don’t see how. Using Nginx for proxy and the nginx user is part of the galaxy group.

ls -l /srv/galaxy/database/dependencies/_conda/bin/conda
-rwxrwxr-x 1 galaxy galaxy 546 Feb 4 14:17 /srv/galaxy/database/dependencies/_conda/bin/conda

galaxy.tool_util.deps.conda_util DEBUG 2021-02-17 11:17:19,307 [p:22990,w:2,m:0] [uWSGIWorker2Core1] Executing command: /srv/galaxy/database/dependencies/_conda/bin/conda create -y --quiet --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --name __fastqc@uv fastqc
galaxy.tool_util.deps.conda_util ERROR 2021-02-17 11:17:19,314 [p:22990,w:2,m:0] [uWSGIWorker2Core1] Failed to execute command: /srv/galaxy/database/dependencies/_conda/bin/conda create -y --quiet --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --name __fastqc@uv fastqc
Traceback (most recent call last):
File “lib/galaxy/tool_util/deps/conda_util.py”, line 237, in exec_command
return self.shell_exec(cmd, env=env, **kwds)
File “lib/galaxy/util/commands.py”, line 55, in shell
p = shell_process(cmds, env, **kwds)
File “lib/galaxy/util/commands.py”, line 85, in shell_process
p = subprocess.Popen(cmds, **popen_kwds)
File “/home/galaxy/.pyenv/versions/3.6.12/lib/python3.6/subprocess.py”, line 729, in init
restore_signals, start_new_session)
File “/home/galaxy/.pyenv/versions/3.6.12/lib/python3.6/subprocess.py”, line 1364, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
PermissionError: [Errno 13] Permission denied: ‘/srv/galaxy/database/dependencies/_conda/bin/conda’

Found the issue! I originally installed galaxy under the root account. Then moved the galaxy folder to another location to run under galaxy user after reading the production docs. So the scripts look to have the original location in them. I’m fixing them as I find them. Is there another way to fix all these using the run.sh?
For example the /srv/galaxy/database/dependencies/_conda/bin/conda file, had to fix the first line:
#!/root/src/galaxy/database/dependencies/_conda/bin/python
To the new location
#!/srv/galaxy/database/dependencies/_conda/bin/python

Although I am not sure if just moving folders is the best way but I can share that you can set the conda path in the config file. You can find the config file here: galaxy/config/galaxy.yml

Thank you. The faster fix was to just copy my galaxy.yml, remove the galaxy install folder, and re-create with the git command. Copy galaxy.yml back in place and then run.sh. Everything looks to be working now!

Well I thought this was fixed but is not. Not sure what to do. When running fastqc still getting error that the command is not found. The Galaxy tool shows it’s installed and all dependencies are checked green

/home/galaxy/galaxy/database/jobs_directory/000/69/tool_script.sh: line 26: fastqc: command not found

Tried uninstalling and reinstalling several times.

Any suggestions??

toolshed.g2.bx.psu.edu/repos/devteam/fastqc/fastqc/0.72+galaxy1

Requirements

fastqc @0.11.8

Status

conda The Conda package manager will be used for resolution. The Conda environment found at /home/galaxy/galaxy/database/dependencies/_conda/envs/__fastqc@0.11.8 will be used for resolution. This dependency is assumed to exactly match the requirement fastqc at version 0.11.8.

Dependency Resolver

A Conda dependency resolver was used with prefix /home/galaxy/galaxy/database/dependencies/_conda and channels iuc,conda-forge,bioconda,defaults. Local Conda packages are enabled for this resolver (this is not best practice for production but may be useful for development).

You could first try to uninstall the dependencies instead of the tool itself and re-run the tool. If it still does not work you can check the log file. If you start galaxy with the command sh run.sh --daemon a default log named galaxy.log will be created. If you see a conda related error you can share it here and hopefully some one can help.

Looks like it not removing the dependencies. From log I it’s not finding several tools:
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,677 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Dependency samtools not found.
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,678 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Using dependency samtools version 1.6 of type conda
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,678 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Dependency pysam not found.
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,678 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Dependency pysam not found.
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,678 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Using dependency pysam version 0.15.4 of type conda
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,679 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Dependency pysam not found.
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,679 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Dependency coreutils not found.
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,679 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Dependency pysam not found.
galaxy.tool_util.deps DEBUG 2021-02-24 08:46:53,679 [p:3275,w:1,m:0] [uWSGIWorker1Core3] Dependency coreutils not found.

I got past the fastqc command not found issue. Not sure what I did other than re-installing the galaxy package again.
However, now getting the following error when trying to run fastqc on a data set.

ln: failed to create symbolic link ‘FASTQ Groomer on data 4’ → ‘’: No such file or directory

Fastq-groomer is installed and checked green on the web app.