Install fastqvalidator

Hello. I want to install fastqvalidator. I do not know how. Please provide proper instructions for a noob. Please do NOT provide a link to other instructions. I read them all, they do not make any sense at all. I do not see an INSTALL button. Do I have to compile everything? I do not know.

Did you made yourself admin? You can do that in the galaxy.yml file. On the admin page you can install tools.

Yep, I go to toolshed and search for fastqvalidator and I get to this page:

Then, I’m stuck.

Nevermind. Works now. Weird, when I tried the first time, the ADMIN part never came up. Now it’s installed - must have been a hiccup. Thanks & Please Close.

NOPE. Now it’s installed, but doesn’t work. Says, missing tool dependencies. How do i figure this mess?

Wow, a lot of my “TOOLS” don’t have the required dependencies. What’s the problem here? Does GALAXY not work properly? How can this be fixed?

Galaxy tools are installed from the Galaxy interface, the toolshed interface is for managing and creating tools, i.e. for tool authors.

Galaxy does not automatically install dependencies of all tools shipped with it, you can use the admin panel’s option ‘manage dependencies’ to install them.

The tool you are trying to use has not been updated since 2013, it also has no bioconda package. That is probably why it does not install properly, and maybe it never did.
I recommend finding a more modern alternative depending on what you are trying to do (fastqgroomer comes to mind).

1 Like

Okay, I’ve had some time to dig through everything, and it seems that one of the biggest issues on my install is the failure of the package bzlib 1.06 to install. The issue appears to be a missing MAKEFILE. The error during the install is: make: *** No targets specified and no makefile found. Stop.Installed tool dependencies: bzlib Can you point to the proper resolution?