GFF3 to GTF conversion

Hi all, I am working on galaxy and have a genome file in genbank format. To use featurecounts for my RNAseq, I need to convert the genbank format to a GTF format because that’s the format the featurecounts tool in galaxy expects. Now, I tried to convert thse genbank to GFF3 using GenbaktoGFF3 tool in galaxy and managed to do so. Also I tried to use the gffread tool to convert the GFF3 file to GTF but this resulted in a GTF with no written lines and I can’t understand why.

Is there a way to directly convert genbank to GTF in galaxy (or even outside galaxy, but preferably in galaxy). Also, any idea why gffread is not working properly in my case? I am using default parameters (leaving everything as is) and only giving GTF as feature file output and track name as “word”.


Hi @anubhavbasu,
could you share your history with me? I’ll have a look at it.

Thanks, I have shared the history with you. The GFF3 file should be #481 BT_Degnan.GFF3. It was made from the genbank file #480

Hi @anubhavbasu,
it seems that this problem has been fixed recently, but the new tool version isn’t available in yet; I have requested to update it; meanwhile, I suggest yo use, since gffread works fine in that instance.


1 Like is now updated, too, thanks! :rocket:

1 Like

A post was split to a new topic: Converting GFF3 to GTF