How to disable auto tool reload?

admin
galaxy-local
galaxy_1709
#1

Hello,

I am using version 17.05. I am trying to disable automatic tool reloading. I know in galaxy.ini “watch_tools = False” won’t disable the automatic reload for the tools that are listed in the tool_conf.xml. Please let me know if there is a way to disable it. Thanks.

BTW, the reason I want to disable reloading is: When there is a running job, if I edit any tool xml file, somehow Galaxy deletes a tmp file when reloading the tools. When the job finishes, it throw an error complaining missing a tmp file. This is annoying because I cannot edit any tool file when there are running jobs. Here is an error message:

Traceback (most recent call last):
File “/scratch/galaxy/job_working_directory/011/11813/set_metadata_LwWNda.py”, line 1, in
from galaxy_ext.metadata.set_metadata import set_metadata; set_metadata()
File “/opt/galaxy/lib/galaxy_ext/metadata/set_metadata.py”, line 85, in set_metadata
datatypes_registry.load_datatypes( root_dir=galaxy_root, config=datatypes_config )
File “/opt/galaxy/lib/galaxy/datatypes/registry.py”, line 106, in load_datatypes
tree = galaxy.util.parse_xml( config )
File “/opt/galaxy/lib/galaxy/util/init.py”, line 214, in parse_xml
root = tree.parse( fname, parser=ElementTree.XMLParser( target=DoctypeSafeCallbackTarget() ) )
File “/usr/lib/python2.7/xml/etree/ElementTree.py”, line 647, in parse
source = open(source, “rb”)
IOError: [Errno 2] No such file or directory: ‘/scratch/galaxy/tmp/tmp4u4oxV’

1 Like

#2

You can disable tool reloading in your (shed_)tool_conf.xml files by changing <toolbox monitor="true"> to <toolbox monitor="false"> . 17.05 is extremely old though, this is a bug we fixed a very long time ago, I’d strongly recommend updating Galaxy to a more recent version.

2 Likes