Missing defined datatypes in community tool suite: qiime2_wrappers

metagenomics
qiime
#1

Currently, i am trying to prepare the workflow for the Qiime2. But unfortunately, the file type for the Qiime2 (QZA,QZV and others) are not present in the list provided with the current version of the Galaxy.
Kindly help me how to add another File type as input for the same problem.

1 Like

#2

Hello,

I’m not sure what protocol you are following, but the datatypes required by these tools as wrapped for Galaxy by the IUC are all supported by the recent Galaxy releases (including the most current, version 19.01).

Each tool form will note the format and datatype of the expected input(s).

The Qiime tools installed at the public Galaxy EU server https://usegalaxy.org have the tool version 1.9.1.N.

Or are you running your own Galaxy server? The IUC version 1.9.1 of the tools installed as a suite (https://toolshed.g2.bx.psu.edu/view/iuc/suite_qiime/a3f284fa7215) should also work in a recent Galaxy version.

Are one of those presenting with a problem? Which tool?

0 Likes

#3

I am using galaxy Versoin 19.01v.

Tool used to run Qiime is
https://toolshed.g2.bx.psu.edu/view/florianbegusch/qiime2_wrappers/51b9b6b57732

It is the wrapper to run Qiime2.
please suggest to resolve the problem faced .

1 Like

#4

Thanks for clarifying.

This is a tool wrapper developed by the larger community. It doesn’t seem to include custom defined datatypes as part of the install instructions/dependencies (and it probably should).

The development repository linked from the ToolShed has one issue (now closed) that is about the same issue you are having: https://github.com/florianbegusch/qiime2_wrappers/issues/1

You could try what the other admin did, to see if it works. If not, open another issue at the repository and see if the developer can offer more support/help.

Your other choice is to use the IUC wrapped version of the tool. This development group includes many members of the core Galaxy team and closely related community contributors, and are a bit easier to reach if there are problems (Gitter chat, etc). Please see: https://galaxyproject.org/iuc/

As a last resort, any tool author can be sent a message through the ToolShed https://usegalaxy/toolshed interface. Create an account first (anyone can), navigate to the tool, and find the option “contact owner” in the “repository actions” menu in the top right corner.

Be aware that whether they reply or not is up to them and the level of support offered. Anyone from the community can contribute tools (on purpose). If there are problems and no support, it is probably a tool you want to avoid.

0 Likes

#5

Hi,

qza is a binary format so you do not have to define a new datatype. The only thing you have to do is to include in the datatypes_conf.xml :

<datatype extension="qza" type="galaxy.datatypes.binary:CompressedZipArchive" display_in_upload="true"/>

2 Likes

#6

Hi,

I’m facing a qiime not found issue when testing qiime2_wrappers after adding the dependences channels in galaxy.yml .

I noticed you solved this by installing via conda env.

However, I’am not sure where to do this? Please suggest to solve this.:stuck_out_tongue:

1 Like

#7

Wecome, @dockerytong!

Two choices:

  • Contact the repository owner for help with getting the installed issues worked out with qiime2_wrappers. The wrapper is older and might not support Conda dependency resolution.

  • Switch to using the IUC version of the tool. It can be found in the ToolShed: https://usegalaxy.org/toolshed

Details for both are in the prior posts in this thread.

Thanks!

0 Likes

#8

Hi,

OK so I managed to make it worked but not sure this is the best way … I first modified galaxy.yml, adding:

conda_ensure_channels:qiime2/label/r2018.4,qiime2,biocore

I had to installed qiime locally with

wget https://data.qiime2.org/distro/core/qiime2-2018.4-py35-linux-conda.yml
conda env create -n __qiime2-2018.4 --file qiime2-2018.4-py35-linux-conda.yml

in the folder _conda/venv and then

conda create -y --override-channels --channel bioconda --channel iuc --channel conda-forge --channel defaults --channel r --channel biocore --name __qiime2@_uv_ qiime
conda create -y --override-channels --channel bioconda --channel iuc --channel conda-forge --channel defaults --channel r --channel qiime2/label/r2018.11 --channel qiime2 --channel biocore --name __qiime2@_uv_ qiime2

Hope this helps,
cheers,

0 Likes