Newbie question regarding installation

Hi - I’ve tried UseGalaxy for the first time today.Very impressed.
I’ve installed Ubuntu, and then followed the instructions to install Galaxy locally.
I’ve tried it a few times (installing dependencies for Python, installing Python 2.7 alongside Python 3 which is already there … … and then finally installing Galaxy) - but get the same error message each time I issue the ‘sh’ command prior to the Galaxy server coming alive.
Many apologies - am sure that I’ve done something very silly.

sb@sb-Lenovo-ideapad-320-14IKB:~/galaxy$ sh
./scripts/ 194: ./scripts/ python: Permission denied
Creating Python virtual environment for Galaxy: .venv
To avoid this, use the --no-create-venv flag or set $GALAXY_VIRTUAL_ENV to an
existing environment before starting Galaxy.
./scripts/ 134: ./scripts/ python: Permission denied

Then - same basic thing with the flag.
sb@sb-Lenovo-ideapad-320-14IKB:~/galaxy$ sh --no-create-venv
./scripts/ 194: ./scripts/ python: not found
./scripts/ 123: ./scripts/ python: not found

Python is definitely installed
sb@sb-Lenovo-ideapad-320-14IKB:~/galaxy$ python2.7 -V
Python 2.7.16

Here (as described in the instructions).
sb@sb-Lenovo-ideapad-320-14IKB:/usr/src$ ls
linux-headers-5.0.0-23 Python-2.7.16
linux-headers-5.0.0-23-generic Python-2.7.16.tgz
linux-headers-5.0.0-29 Python-2.7.16.tgz.1

Thanks, SB.


./scripts/ 194: ./scripts/ python: Permission denied

Check the rights of the galaxy folder. It is also recommended that you create a new galaxy user and use this user to install galaxy with the right permissions etc.

Python is definitely installed

I think python 2.7 need to able to be executed like python and not like python2.7



I’ll give those ideas a go but am not really too sure of what I’m doing.
I’ve been using:

  • for instructions.

You haven’t seen any more detailed instructions for those of us in need :-).

It should be relatively simple but I suspect that it’s all something (As you suggest) to do with Python 3 and 2 living together despite putting in the symbolic link listed in the instrucions.

Thanks, SB.

Hi. Thanks for the help.
In the end managed to get it working by installing it inside Ubuntu inside VirtualBox inside Windows. Couldn’t make it work inside Ubuntu firect. The only difference between the two Ubuntus were that the image did not seem to have Python 3.
So - if anybody has instructions on how to make it work alongside Python 3 - woule be grateful.
These instructions didn’t work for me.