Nginx reverse proxy local Galaxy instance does not upload data

Hi all,

I have setup a local Galaxy server on a headless ubuntu server follow this website.
Locally (http://localhost:8080), everything works fine. I can upload data en install tools. Currently, I am trying to make the Galaxy server available through reverse proxy using this website. The Galaxy server is reachable through but now if I want to upload data or install tools nothing happens.
I have tried proxying using Nginx Proxy Manager and by just using nginx but nothings works.

Any ideas?

Thanks in advance!

Hi @zmeel

Resources. It looks like you already found the second, but maybe not the first?

Have you already checked the logs? You need to add the following line to the configuration file:
error_log /var/log/nginx/error.log;
You can choose any path you want, and you need to restart nginx after changing the configuration.

Or do you see something in the logs of galaxy?

1 Like

I have reinstalled Galaxy and now use the reverse proxy (Apache) of my Synology NAS but still no upload. Then I checked the console of my browser and saw the following errors:

httpStack.js?acdc:96 Mixed Content: The page at '' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ''. This request has been blocked; the content must be served over HTTPS.

Failed because: Error: tus: failed to resume upload, caused by [object ProgressEvent], originated from request (method: HEAD, url:, response code: n/a, response text: n/a, request id: n/a)`
`, will retry in 10 seconds

At least I have an error now…

Okay. Fixed this. It was the same as this issue:
proxy_set_header X-Forwarded-Proto $scheme; causes Chrome to block the upload request. The solution was amazingly simple: proxy_set_header X-Forwarded-Proto "hppts";