rstudio connection to galaxy

Hi all,
i tried rstudio as interactive tool, however, the proposed commands of gx_put() and gx_get() seem not to work in the moment. Please find the received error message in the console of rstudio in the screenshot below.

Is it still not working for you?
For me, everything’s ok.

No, still not working on the instance, however, other instances like w4m work for me.

and I assume you have tried this from several RStudio instances (i.e. several runs of the RStudio tool) by now?

yes, all show the same error

Puh, we cannot reproduce your issue currently, so this isn’t exactly easy to debug, but let’s try narrowing things down with a couple of questions:

Have you ever had this working before? If so, when did you last use RStudio successfully? If not, when was your first attempt to use the tool?

Have you always tried this from the same history? If so, is there something special about this history (e.g. has it not been created by you but been shared with you by somebody else)?

If you just create a new history and run RStudio from there, does that work? You can simply import try with gx_get(0) (no need to create a dataset in the new history first - you’ll get a KeyError if things “work”, which would tell us that the connection got established).

So, i am capable of running an interactive working studio session on other instances (subdomains of, but I observed this error every time I try it on the instance (last weeks, several times, different histories)…i can try to send you any job ids or share the history with you if that might helps…
This screenshot is just some minutes ago again with a new history, created by me, also only few minutes ago:

Ok, lets see how much info we need, but for a start can you confirm your user name on Galaxy Europe (my guess would be oracxl)?

yes, correct

Alright, then lets do further debugging via mail (you should have received one already).