SnpEff errors while trying to run the tool

Hi, I have been trying to run SnpEff in Galaxy, but have been facing a number of issues that I am not sure how to resolve.

Background: I am analysis different strains of Mycobacterium tuberculosis. I have created a vcf file, and would now like to see the effects of my variants, hence I am using SnpEff.


  1. When I use the SnpEff download tool to download the SnpEff database for Mycobacterium_tuberculosis_h37rv, the tool runs successfully but outputs a file with only 2 lines. (SnpEff version number and Mycobacterium tuberculosis H37Rv).

I tried using the SnpEff build tool as well with the Genbank annotation file, however it results in the same 2 line output.

  1. Because of this problem, I directly downloaded the SnpEff database from SourceForge, and uploaded the file as a Snpeffdb to galaxy. This file however, shows as ‘unavailable’ in SnpEff eff. The issue might be with the metadata, which I am not able to edit manually and autodetect does not work.

As you can see I have tried all the approaches I can think of and nothing seems to work. I even used the version. Please help, I am new to NGS analysis and will appreciate any guidance.

@jennaj @wm75

1 Like

Hmm, from your description (which is very detailed BTW - thanks for that!) there does not seem to be anything wrong here. Those two lines of output are how Galaxy presents the newly downloaded genome to you. After all, SnpEff genome files are kept in a binary format and there is not really a more helpful way to display that data.

What you should try next is to go to the SnpEff eff tool, select Downloaded snpEff database in your history under Genome source, and the version you downloaded via SnpEff download should be offered as a choice.

Building the genome file yourself should also work, but is not recommended if there’s an exisitng genome for download. Such genomes should be offered if you select Custom snpEff database in your history as the Genome source.

Uploading an externally built SnpEff genome to a Galaxy history is not currently supported.

Let us know if you keep facing issues and best wishes,

1 Like

Thank you so much for your prompt response. It worked!

Linked Q&A: How to add Triticum aestivum snpEff4.3 genome database or appropriate wheat genome database in Galaxy for VCF annotation?