toolshed broken after removing a folder

I didn’t see any topic about my problem.
I tried to follow the steps to submit with planemo a new tool on my toolshed. Then, I wanted to remove the tool but with the admin interface nothing to do that. After some search, I removed the repository located in /database/community_files/000/repo_1 and… this is the drama.
I understood that it’s not just a simple directory but also mercurial managment and sqlite database…
And now impossible to restart the toolshed using the using the

Traceback (most recent call last):
  File "lib/tool_shed/webapp/", line 65, in app_factory
    app = UniverseApplication(global_conf=global_conf, **kwargs)
  File "lib/tool_shed/webapp/", line 95, in __init__
    self.repository_registry = tool_shed.repository_registry.Registry(self)
  File "lib/tool_shed/", line 18, in __init__
    self.certified_level_one_clause_list = self.get_certified_level_one_clause_list()
  File "lib/tool_shed/", line 146, in get_certified_level_one_clause_list
    certified_level_one_tuple = self.get_certified_level_one_tuple(repository)
  File "lib/tool_shed/", line 164, in get_certified_level_one_tuple
    latest_installable_changeset_revision = metadata_util.get_latest_downloadable_changeset_revision(, repository)
  File "lib/tool_shed/util/", line 93, in get_latest_downloadable_changeset_revision
    repository_tip = repository.tip()
  File "lib/tool_shed/webapp/model/", line 331, in tip
    repo = self.hg_repo
  File "lib/tool_shed/webapp/model/", line 219, in hg_repo
    WEAK_HG_REPO_CACHE[self] = hg.cachedlocalrepo(hg.repository(ui.ui(), self.repo_path().encode('utf-8')))
  File "/storage/galaxydev/aubi/venv/lib64/python3.6/site-packages/mercurial/", line 231, in repository
  File "/storage/galaxydev/aubi/venv/lib64/python3.6/site-packages/mercurial/", line 193, in _peerorrepo
    ui, path, create, intents=intents, createopts=createopts
  File "/storage/galaxydev/aubi/venv/lib64/python3.6/site-packages/mercurial/", line 3350, in instance
    return makelocalrepository(ui, localpath, intents=intents)
  File "/storage/galaxydev/aubi/venv/lib64/python3.6/site-packages/mercurial/", line 546, in makelocalrepository
    raise error.RepoError(_(b'repository %s not found') % path)
mercurial.error.RepoError: b'repository /storage/galaxydev/aubi/galaxy21.05/database/community_files/000/repo_1 not found'

I tried to re-create the folder and I add a copy of another folder repo_2 to mimic the path but now, the toolshed started but nothing happen…

Finally, I reset the sqlite database and associated files before completely restart a new toolshed