Error attempting to retrieve installation information from tool shed

Hello,

I tried to install the toolshed tools on my local Galaxy, but I get an error both when I use the shed-tools command and from the web browser. Is it currently unable to install from toolshed? I think I was able to do it last week.

The error message is as follows

shed-tools install -g http://127.0.0.1:{PORT} -a ${API_KEY} -t test_tools_list.yaml
Storing log file in: /tmp/ephemeris_iSknFb
(1/1) Installing repository breseq from iuc to section “Breseq” at revision 85c57cc9b558 (TRT: 0:00:01.373036)
Error installing a repository (after 0:00:01.281213 seconds)! Name: breseq,owner: iuc, revision: 85c57cc9b558, error: {“err_msg”: “Error attempting to retrieve installation information from tool shed https://toolshed.g2.bx.psu.edu/ for revision 85c57cc9b558 of repository breseq owned by iuc: HTTP Error 500: Internal Server Error”, “err_code”: 500001}
Installed repositories (0): []
Skipped repositories (0): []
Errored repositories (1): [(‘breseq’, ‘85c57cc9b558’)]
All repositories have been installed.

Best,
Yukie

1 Like

It seemed to be temporary. Now it works.

Thank you,
Yukie

1 Like

Hi @yukieymd

Both the Main and Test ToolSheds were recently undergoing updates. Issues around that are resolved as of earlier today.

Related Q&A:

Thanks!