Problems when installing tools in local installation

Hello, I recently installed local Galaxy on a Xubuntu machine (most recent version 19.05). I setup admin user correctly, and when I tried to install tools from the default tool shed, I always get an error. For some reason I cannot clone the repository for the installation, giving an “abort: connection ended unexpectedly” with an error code 255.

I tried with different tools and got the same result. I don’t know where to start looking for possible causes, so if anyone may have some suggestions, I will be happy to provide more information. Thank you!

1 Like

hi Antonio,
Can you post more information about the error? for example the part of uwsgi.log that contain it.

1 Like

I am having the exact same issue this morning. My guess it the toolshed is down.
I know they are migrating the toolshed these last few days.

1 Like

Are you sure that the toolshed is down? what about the test-toolshed?

Sorry, turns out I had a different issue.

There was an issue with the toolshed yesterday but has since been resolved.

Try installing the tool again and see if it was related.

You should allow Galaxy accessing the internet.
You could try to modify the file “galaxy/config/galaxy.yml” by changing the line “http: 127.0.0.1:8080” with “http:0.0.0.0:8080” or another port like “http:0.0.0.0:7070”.

That settings affects where Galaxy listens for traffic, it has nothing to do with Galaxy being able to access internet. Even local Galaxies with private IP like 127.0.0.1 can install tools from the Toolshed.

1 Like

Please try again now and report if it does not work. Toolshed has had some hiccups in the past days and it might have affected your tool installation.

1 Like

Hi. I think I ran into the same problem today. Trying to install freebayes and ran into got this:

Error cloning repository: Command ‘[‘hg’, ‘clone’, ‘-r’, u’29’, u’https://toolshed.g2.bx.psu.edu/repos/devteam/freebayes’, u’/home/xxxxx/galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/freebayes/156b60c1530f/freebayes’]’ returned non-zero exit status 255

Any help is appreciated. Thank you!

It should be fixed now, thanks for the report and sorry for the inconvenience.

1 Like

hi I ran into the same error of @phemarajata today, trying to install fastQC

Error cloning repository: Command ‘[‘hg’, ‘clone’, ‘-r’, u’21’, u’https://toolshed.g2.bx.psu.edu/repos/devteam/fastqc’, u’/home/galaxy/galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/fastqc/e7b2202befea/fastqc’]’ returned non-zero exit status 255
Output was:
abort: connection ended unexpectedly

Fixed. Sorry again and thanks for reporting. We are working on a long term solution.

3 Likes