toolshed not working anymore with old galaxy?

Hi all,

since some months we are having an issue with the toolshed. It’s not installing any tools anymore printing the following error:
“Repository installation is not possible due to an invalid Galaxy URL: None. You may need to enable third-party cookies in your browser.”
I tried the enabling of third party cookies but it does not change anything.
Our instance is quite old (16.07) but a the moment we cannnot update.

Is there anything I can do to get access to the toolshed again?

I found a number of related topics, which are not helping with my problem:

Cheers
Jochen

2 Likes

Hi Jochen @bimbam23

I’ve asked your question on the developer’s gitter channel to see if there are any more potential solutions. They may answer here or there and you can certainly join in the chat: galaxyproject/dev - Gitter

My guess is that the upgrades that occurred this week are incompatible with the version of Galaxy you are using – or are incompatible right now – but let’s get more advice.

Good to see you (virtually) again!

Hej Jenn,

thanks for helping and good to hear from you too :slight_smile:

I will have a look at the gitter channel

Cheers Jochen

1 Like

Hi Jochen,

I have exactly the same problem - older Galaxy version (16.?) and cannot install any new tools. What did you find out and/or end up doing??

Best
Michael

Hi Michael,

I could not solve the problem. I might have to install a new galaxy version in the future… Updating from 16 …might be a bit difficult I guess.

Cheers
Jochen

Thanks for the information! Yes - I tried to update from version 16 (I think to 19) last year and could it kept failing.

We purchased Galaxy already installed on a Linux server from Bioteam - who maintained the updates until 2019 (i.e. Version 16). Unfortunately they stopped supporting us (and everyone else I gather) - but kindly left instructions on how to update it - which didn’t work. Since then we haven’t needed to update - until now when the Toolshed stopped working.

If you having any advice on updating - let me know.

Thanks
Michael

1 Like

For some details check out release 20.09 possibly broke the ability to install tools · Issue #11746 · galaxyproject/galaxy · GitHub

tldr: you have to update

2 Likes

To add, if you’re running into problems updating your Galaxy instances, let us know.
For such old releases I’d recommend doing year-by-year updates.

So if you start on release_16.01, I’d recommend updating to release_17.01, doing the database migrations (./manage_db.sh -c config/galaxy.ini), start up Galaxy and verify the interface works, and then going to release_18.01 and so on. Once you reach release_20.01 you have to migrate to Python 3, instructions for updating this are here: Supported Python versions — Galaxy Project 21.01 documentation

1 Like

Thanks for the tips. I did try to upgrade from 16 to 19 directly - but I guess I was too greedy. You guys do such a good job of putting out updates that it is hard to keep up.

In a similar vein - apart from Python 3 - do the newer Galaxy versions have higher Linux version requirements??

Not that I am aware of, as long as you can install Python 3 somehow you should be good