Updated to 19.09: Tool-Menu Items Disappear

Local Galaxy instance.
I upgraded my local galaxy instance to 19.09 from 19.04. No initial issues were observed. No errors.

When I restart Galaxy, all installed “shed_tools” disappear from my gui tools menu. Interesting …
If I delete the intergrated_tool_panel.xml file, the shed_tools reappear in the gui menu when I restart.
Restarting again, and the tools disappear.
It would appear that while the shed_tools are added to the GUI menu correctly, they do not appear to be added to the integrated_tool_panel.xml file ( The contents of tools_config.xml is added to the file, but the shed_tools are never added to this file). If you restart, galaxy reads from the integrated_tools_panel.xml file and therefore no shed_tools. Delete the file and it works until restart.
Any ideas, this one is beyond me…
Regards,
Mat

I am a bit confused about your report. Could you please clarify what sequence of actions make the tools appear? Also check the startup logs for whether the specific tools load or not, every tool has a line there.

Hi Martin, thanks for the fast reply.
The only way I have found to make the tools reappear is to delete the intergrated_tool_panel.xml file.
Once you do this, when you restart, the shed_tools are in the gui panel, and Galaxy creates a new integrated_tool_panel.xml file.

If you restart without deleting this file, the menu does not contain the shed_tools.

To directly answer your question, yes I can see the tools being loaded in the log on startup.
I also noted that the contents of the integrated_tool_panel.xml file never contains the parsed shed_tools.xml file. It only ever contains the parsed contents of the tool_panel.xml file. Hence when you restart, Galaxy appears to load this file directly, instead of creating the menu from tool_panel, and shed_tools_panel etc.

I hope that makes sense…

Kind regards,

Mat

Thanks for elaborating, it indeed sounds tricky. Any errors in the log you can see? Is the location of your configuration files special in any way? How many tool configuration files do you use?

that’s an interesting bug … what are the values of tool_config_file, integrated_tool_panel_config and shed_tool_config_file in your galaxy.yml file? Is the restart behavior fixed if you set shed_tool_config_file to your shed_tool_conf.xml file?

Yep, I’m dangerous enough to solve most simple issues…
I have some home-grown tools in the tools_config.xml file, but I swapped this file out for the .sample file. The issue persisted.
I am now checking the shed_tools.config file to see if there is an xml format error of some sort…
I’ll let you know.
Mat

Hi Marius,
Thanks for the reply.
Values are default. I run a pretty standard config, so when I update I merge the new galaxy.yml file with the old file. I don’t believe I have changed those values ever.

When I get a chance I’ll go look for the shed_tool_config_file and explicitly set it in galaxy.
Thanks for replying on a Saturday, I appreciate it, but surely you guys have better things to do :slight_smile:
P.S, this Galaxy instance has been running for a number of years, and upgraded several times. Undoubtedly I’ve done something stupid, probably a while ago, I just can’t find the where :slight_smile:

Regards,

Mat

We did change the way default values for shed_tool_config_file are treated in 19.09 while preparing for pip-installable Galaxy, so it is well possible that you didn’t do anything wrong.

Yes, uncommenting the shed_tool_config line in galaxy.yml resolved the issue.

#tool_config_file: config/tool_conf.xml
shed_tool_config_file: config/shed_tool_conf.xml

Once I removed the “#”, it worked. Interestingly, I did not need to uncomment the line tool_config.xml in galaxy.yml.

Thank you all!!

Regards,

Mat

2 Likes