2 galaxy.yml for Admin acces, why ?

Hi everyone,

I want to use the tool GIANT so I need to be an admin on a galaxy session. So, I installed Galaxy on local instance with Ubuntu. I saw I had to modify a galaxy.yml file by adding my email adress.
For that, I use $ config/galaxy.yml.sample config.galaxy.yml and it works. The problem is this file is in a wrong file and when I try to open galaxy.yml.sample, it does’t work. So, I searched the galaxy.yml.sample elsewhere and I find it in “Galaxy”–> “Config” → “Sample” and when I want to open it, it work.
So I tried to make a .yml from .yml.sample but it doesn’t work on Ubuntu : file not found
I tried to copy/paste the galaxy.yml which is in the wrong place in “Galaxy” → “Config” → “Sample” but it’s doesn’t work either.

So, why I have 2 galaxy.yml.sample and how can fix the problem to finally be Admin in my local instance ?

Thank you very much,

I am not fully understanding the problem but mostly you just do
cp config/galaxy.yml.sample config/galaxy.yml
after installation.
And from this moment you only use config/galaxy.yml. You do need to restart galaxy after adding a admin.

Is this what you also did? I know there is some symlinking with galaxy.yml.sample but you dont have to worry about it that.

1 Like

Yes I dot that, I put my email in galaxy.yml after doing cp config/galaxy.yml.sample config.galaxy.yml but it doesn’t work.

I restart galaxy and my computer but it still not work.

So I am assuming now that you did cp config/galaxy.yml.sample config/galaxy.yml, added your email to the admin settings and restarted galaxy. Did you made an account on your local galaxy and logged in with that account? If yes, can you show how the line in your yaml file looks like. You can (need) to anonymize the email adres, it is only about the format.

1 Like