Account cannot be accessed and unable to reset password

Dear admin,

I cannot access my Galaxy account for the past week, whenever I tried to login to my account, the system states that it fails to submit email and requires me to contact the administrator. I also tried resetting the password but failed as well.

I further attempted to register a new account using a different email, unfortunately no verification email was sent to me and log-in access was not granted as the system states I have not activated my account.

As I am using the Galaxy system for my university assignment, I need to prove that it was a system error with some evidence such as an email reply.

Kindly advise me on this matter. Thank you for your attention.

1 Like

Hi @Steffi_Chan

To help, we need to know which Galaxy server are you working at. Please post back the server URL.

1 Like

Hi @jennaj,

Thank you for your prompt reply. My Galaxy server is

@Steffi_Chan I’m afraid you need to contact the admins of this particular server. Please have a look here: