Add private conda channel

conda
admin

#1

Hi everybody,

I’m asking if it is possible to add private conda channel to use in Galaxy. I use conda on the same server and can add a private channel with conda config --add channels file//<path_to_my_channel>.
Resulting in this :
$ conda info

     active environment : None
       user config file : /home/XXX/.condarc
 populated config files : /home/XXX/.condarc
          conda version : 4.5.12
    conda-build version : 3.17.6
         python version : 3.6.6.final.0
       base environment : /home/XXX/miniconda3  (writable)
           channel URLs : file://tmp/conCAPSID/linux-64
                          file://tmp/conCAPSID/noarch
                          https://conda.anaconda.org/conda-forge/linux-64
                          https://conda.anaconda.org/conda-forge/noarch
                          https://repo.anaconda.com/pkgs/main/linux-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/free/linux-64
                          https://repo.anaconda.com/pkgs/free/noarch
                          https://repo.anaconda.com/pkgs/r/linux-64
                          https://repo.anaconda.com/pkgs/r/noarch
                          https://repo.anaconda.com/pkgs/pro/linux-64
                          https://repo.anaconda.com/pkgs/pro/noarch
          package cache : /home/XXX/miniconda3/pkgs
                          /home/XXX/.conda/pkgs
       envs directories : /home/XXX/miniconda3/envs
                          /home/XXX/.conda/envs
               platform : linux-64
             user-agent : conda/4.5.12 requests/2.18.4 CPython/3.6.6 Linux/4.4.0-116-generic ubuntu/16.04 glibc/2.23
                UID:GID : 658240:200198
             netrc file : None
           offline mode : False

Is it possible to do the same under galaxy ?
Thanks in advance :slight_smile:


#2

Because when I run the job in galaxy interface, I get the following error :
PackageNotFoundError: Packages missing in current channels:

  - pdb2fasta

We have searched for the packages in the following channels:
            
  - https://conda.anaconda.org/conCAPSID/linux-64
  - https://conda.anaconda.org/conCAPSID/noarch
  - https://conda.anaconda.org/iuc/linux-64
  - https://conda.anaconda.org/iuc/noarch
  - https://conda.anaconda.org/conda-forge/linux-64
  - https://conda.anaconda.org/conda-forge/noarch
  - https://conda.anaconda.org/bioconda/linux-64
  - https://conda.anaconda.org/bioconda/noarch
  - https://repo.continuum.io/pkgs/main/linux-64
  - https://repo.continuum.io/pkgs/main/noarch
  - https://repo.continuum.io/pkgs/free/linux-64
  - https://repo.continuum.io/pkgs/free/noarch
  - https://repo.continuum.io/pkgs/r/linux-64
  - https://repo.continuum.io/pkgs/r/noarch
  - https://repo.continuum.io/pkgs/pro/linux-64
  - https://repo.continuum.io/pkgs/pro/noarch

Galaxy search in https://conda.anaconda.org/conCAPSID/noarch instead of file//<path_to_my_channel>


#3

You can add custom conda channels for Galaxy to use using the conda_ensure_channels setting


#4

Nice thanks it’s working !!

In fact, I thought it was enough to add the path to the private channel in the conda configuration using conda config --add channels "file: // <path_to_channel>" and that it was necessary to add the name of the channel in conda_ensure_channels. But that does not work.

Just add file://<path_to_channel> in conda_ensure_channels and it works!